ansible-galaxy fails to validate the SSL certificateurlopen error SSL CERTIFICATE VERIFY FAILED RROR - you can use --ignore-errors to skip failed roles and finish processing the list

0 votes

Hi Guys,

I am trying to install one role from Ansible Galaxy. But it is showing me the below error.

$ ansible-galaxy role install apache
[WARNING]: - ntp was NOT installed successfully: Failed to get data from the API server (
<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:748)>
ERROR! - you can use --ignore-errors to skip failed roles and finish processing the list.
Aug 28, 2020 in Ansible by MD
• 95,320 points

1 answer to this question.

0 votes


The most probable reason is that you are using an older version of python. I also faced the problem. Then I installed Python3 via brew and it solved my issue. Python 2 might have worked too since it would have been linked to a new OpenSSL.

answered Aug 28, 2020 by akhtar
• 38,230 points

Related Questions In Ansible

0 votes
1 answer
+1 vote
3 answers
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 27, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
+2 votes
1 answer
0 votes
1 answer

ansible ssh and user module issue with edureka VM

Hi@Konakanchl, I guess you need to give your ...READ MORE

answered Jul 23, 2020 in Ansible by akhtar
• 38,230 points
0 votes
1 answer

How to replace a line using lineinfile module in Ansible?

Hi@MD, You can use lineinfile module in Ansible. ...READ MORE

answered Sep 2, 2020 in Ansible by akhtar
• 38,230 points