Unable to host from private build agent in team services

0 votes

I am using Azure Team Services with a private build agent. There's a build task that builds and publishes the build artifact and a release task that pings the server.

Tool: ping 
Arguments: MyServerXXX

But the release task is failing:

2017-06-01T12:51:48.4030953Z ##[command]ping MyServerXXX
2017-06-01T12:51:48.6090956Z Ping request could not find host MyServerXXX. Please check the name and try again.

Both the build agent and myserver are part of the same domain. I successfully can log onto the build server and ping the server. I am using a domain account running inside the build agent that has access to the server. I also tried a fully qualified name. The command works in the build definition but how can I make it work in the release pipeline?

Jun 14, 2018 in DevOps on Cloud by shubham
• 6,590 points
29 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

Check if you're deployent queue is hosted or default. If it's hosted change it to default. Also run it on agent by clicking on Run on Agent.

answered Jun 14, 2018 by ajs3033
• 7,080 points

Related Questions In DevOps on Cloud

+2 votes
2 answers
+4 votes
2 answers

unable to get subdomain of URL in NGINX

You just need to add .+ after ...READ MORE

answered Oct 11, 2018 in DevOps on Cloud by lina
• 8,100 points
495 views
0 votes
1 answer

Fetch AzureVm name from private IP in powershell

If by a better way you mean ...READ MORE

answered Jul 17, 2018 in DevOps on Cloud by DareDev
• 6,670 points
142 views
+3 votes
2 answers
0 votes
1 answer
+13 votes
2 answers
0 votes
1 answer
0 votes
1 answer

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.