Error: Ruby run error after connecting puppet apply to PuppetDB.

0 votes
Puppet resource generates Ruby errors after connecting puppet apply to PuppetDB. How do i troubleshoot?
Jul 31 in Puppet by Sam
• 1,520 points
21 views

1 answer to this question.

0 votes
  • If Puppet apply is configured incorrectly, this error is encountered. 

  • For example by modifying puppet.conf to add the parameters storeconfigs_backend = puppetdb and storeconfigs = true in both the main and master sections, puppet resource ceases to function.

  • This will display a Ruby run error.

  • Modify /etc/puppetlabs/puppet/routes.yaml to correctly connect puppet apply without affecting other functions.

  • This would do!

answered Jul 31 by Sirajul
• 25,420 points

Related Questions In Puppet

0 votes
1 answer

Error: Puppet not found, when trying to run puppet config command.

This is because you have not added ...READ MORE

answered 6 hours ago in Puppet by Sirajul
• 25,420 points
5 views
0 votes
1 answer

Error while trying to instal mssql tools using puppet

When you use puppet, you don't use ...READ MORE

answered Feb 25 in Puppet by Nandita
92 views
0 votes
1 answer

How does Puppet apply configuration to agent nodes?

Puppet follows this workflow: There is a factor ...READ MORE

answered Mar 8 in Puppet by Veena
83 views
0 votes
1 answer

Apply module to puppet client.

Add this to site.pp: node 'fqdn of client' ...READ MORE

answered Mar 12 in Puppet by Yesha
31 views
+13 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,380 points
147 views
0 votes
1 answer
0 votes
1 answer

Puppet Error: Unable to locate package PuppetDB

You will have to enable the puppet ...READ MORE

answered Aug 6 in Puppet by Sirajul
• 25,420 points
16 views