error Could not parse for environment production Syntax error at expected at Users adrien puppetlabs-mrepo manifests repo pp 252err Try puppet help parser validate for usage

0 votes

Hi Team,

I am trying to run the puppet parser command, but it is showing me the below error.

$ puppet parser validate
err: Could not parse for environment production: Syntax error at ‘{‘; expected '}' at /Users/adrien/puppetlabs-mrepo/manifests/repo.pp:252
err: Try 'puppet help parser validate' for usage
Dec 31, 2020 in Puppet by akhtar
• 38,170 points
111 views

1 answer to this question.

0 votes

Hi@akhtar,

You are getting this error because there is a syntax error in your code. You may miss one curly bracket in your code. You need to check your code, or you can paste it here.

answered Dec 31, 2020 by MD
• 95,160 points

Related Questions In Puppet

0 votes
1 answer

Puppet: Error: Could not parse for environment production: Syntax error at '='; expected '}'

This error occurs if puppet apply -e is used ...READ MORE

answered Aug 1, 2019 in Puppet by Sirajul
• 59,050 points
1,471 views
0 votes
1 answer

Error saying "Error: Could not parse for environment production" - Puppet

Hey @Nagya, You need to set the ...READ MORE

answered Feb 15, 2019 in Puppet by Kavya
1,004 views
0 votes
1 answer
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
1,064 views
+2 votes
1 answer
0 votes
1 answer

How to check the syntax of Puppet DSL code?

Hi@akhtar, At the lowest level of checking, you ...READ MORE

answered Dec 31, 2020 in Puppet by MD
• 95,160 points
64 views