Puppet Error: Unable to locate package PuppetDB

0 votes

I have just begun with puppet. I have installed the puppet server(master)6.7 on ubuntu 16.10, a linux puppet agent, and a windows agent.

After this i followed the official docs to install PuppetDB. I have connected it with my server.When I run puppet agent --test it successfully completes.and when I run sudo /opt/puppetlabs/puppet/bin/puppet resource package puppetdb ensure=latest here is an error:

error: Unable to locate package PuppetDB

How do i set it right?

Aug 6, 2019 in Puppet by Sarah
157 views

1 answer to this question.

0 votes
  • You will have to enable the puppet collection package.

  • Enabling the Puppet Collection package repository for Xenial solves the problem with, particularly puppetserver and puppetdb packages on Ubuntu16.10.

  • For later versions of puppet (6.7 etc) you will have to enable puppet platform repository. 

answered Aug 6, 2019 by Sirajul
• 57,940 points

Related Questions In Puppet

0 votes
1 answer

Error saying "Error: Could not autoload puppet/provider/package/rpm: No child processes." While installing gcc through puppet

Hey @Laksha, check your internet connectivity. You usually ...READ MORE

answered Feb 15, 2019 in Puppet by Jugnu
192 views
0 votes
1 answer

Error while trying to instal mssql tools using puppet

When you use puppet, you don't use ...READ MORE

answered Feb 25, 2019 in Puppet by Nandita
386 views
0 votes
1 answer

Error saying "Package[pacman]/ensure: change from absent to present failed: Could not find package pacman"

Hey @Dipti, Add --debug --verbose to see the command ...READ MORE

answered Feb 25, 2019 in Puppet by Nandita
99 views
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
681 views
+2 votes
1 answer
0 votes
1 answer

Error: Ruby run error after connecting puppet apply to PuppetDB.

If Puppet apply is configured incorrectly, this error is ...READ MORE

answered Jul 31, 2019 in Puppet by Sirajul
• 57,940 points
89 views