Hyperledger Fabric: Not able to install docker

0 votes

I am trying to run

sudo apt-get install docker-engine. 

But I get error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 Docker-engine: Depends: init-system-helpers (>= 1.13~) but it is not installable
                 Depends: sysv-rc (>= 2.88dsf-24) but 2.88dsf-13.10ubuntu11 is to be installed or
                          file-rc (>= 0.8.16) but it is not installable
                 Depends: libc6 (>= 2.17) but 2.15-0ubuntu10 is to be installed
                 Depends: libdevmapper1.02.1 (>= 2:1.02.63) but 2:1.02.48-4ubuntu7 is to be installed
                 Depends: libsystemd-journal0 (>= 201) but it is not installable
                 Recommends: aufs-tools but it is not going to be installed
                 Recommends: cgroupfs-mount but it is not installable or
                             cgroup-lite but it is not going to be installed
                 Recommends: git but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How to solve this error?

Nov 2, 2018 in Blockchain by slayer
• 29,170 points
110 views

1 answer to this question.

0 votes

Clean up the invalid package repository:

cd ../../etc/apt/sources.list.d
sudo rm docker.list

Then add the repository and update:

sudo apt-add-repository 'deb https://apt.dockerproject.org/repo ubuntu-xenial main'
sudo apt-get update
sudo apt-get install docker-engine
answered Nov 2, 2018 by Omkar
• 67,660 points

Related Questions In Blockchain

0 votes
1 answer

Not Able to register a user with Hyperledger-Fabric v1.1 preview

The error: "Certificate not found with AKI 'e729224e8b3f31784c8a93c5b8ef6f4c1c91d9e6e577c45c33163609fe40011' ...READ MORE

answered Jun 16, 2018 in Blockchain by charlie_brown
• 7,720 points
438 views
0 votes
1 answer

Hyperledger Composer: not able to install Hyperledger composer-cli

Try setting the PATH like this, export PATH="/usr/local/share/npm/bin:$PATH" Now run the ...READ MORE

answered Oct 31, 2018 in Blockchain by Omkar
• 67,660 points
279 views
+1 vote
3 answers
0 votes
1 answer
0 votes
1 answer
0 votes
3 answers
0 votes
1 answer
0 votes
2 answers

Not able to POST chaincode to hyperledger-fabric using API

TypeError: Cannot read property 'curve' of undefined     at ...READ MORE

answered Jan 30 in Blockchain by SHRADDHA
105 views