Hyperledger Composer: not able to install Hyperledger composer-cli

0 votes

When I run:

$ ./createPeerAdminCard.sh

I get this :

"Development only script for Hyperledger Fabric control
Running 'createPeerAdminCard.sh'
FABRIC_VERSION is unset, assuming hlfv11
FABRIC_START_TIMEOUT is unset, assuming 15 (seconds)
No version of composer-cli has been detected, you need to install composer-cli at v0.19 or higher."

But I have already installed it using:

$ npm install -g composer-cli

And I have got:

+ composer-cli@0.19.2 added 568 packages from 473 contributors in 58.747s

Please tell me how to install Hyperledger Composer.

Oct 31, 2018 in Blockchain by slayer
• 29,050 points
245 views

1 answer to this question.

0 votes

Try setting the PATH like this,

export PATH="/usr/local/share/npm/bin:$PATH"

Now run the command again:

$ ./createPeerAdminCard.sh

answered Oct 31, 2018 by Omkar
• 67,480 points

Related Questions In Blockchain

0 votes
1 answer

Hyperledger Composer: Not able to query fabric.

Add another rule to .acl file to ...READ MORE

answered Nov 12, 2018 in Blockchain by Omkar
• 67,480 points
53 views
0 votes
1 answer

Not Able to register a user with Hyperledger-Fabric v1.1 preview

The error: "Certificate not found with AKI 'e729224e8b3f31784c8a93c5b8ef6f4c1c91d9e6e577c45c33163609fe40011' ...READ MORE

answered Jun 16, 2018 in Blockchain by charlie_brown
• 7,720 points
395 views
0 votes
1 answer
0 votes
1 answer

How to solve "error trying install composer runtime" in Hyperledger composer?

I think the docker-compose tool is not ...READ MORE

answered Jul 17, 2018 in Blockchain by slayer
• 29,050 points
81 views
0 votes
1 answer
+1 vote
1 answer

I am unable to change port of composer-rest-server. Please help!

Use full format for running a business ...READ MORE

answered Mar 27, 2018 in Blockchain by Christine
• 15,790 points
280 views
+1 vote
1 answer
0 votes
1 answer

Hyperledger Fabric: Not able to install docker

Clean up the invalid package repository: cd ../../etc/apt/sources.list.d sudo ...READ MORE

answered Nov 2, 2018 in Blockchain by Omkar
• 67,480 points
79 views
0 votes
1 answer

Hyperledger composer: Not able to issue identities from a Business network.

To specify your own affiliation you need ...READ MORE

answered Nov 6, 2018 in Blockchain by Omkar
• 67,480 points
244 views