I am trying to run
sudo apt-get install docker-engine.
But I get error:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
Docker-engine: Depends: init-system-helpers (>= 1.13~) but it is not installable
Depends: sysv-rc (>= 2.88dsf-24) but 2.88dsf-13.10ubuntu11 is to be installed or
file-rc (>= 0.8.16) but it is not installable
Depends: libc6 (>= 2.17) but 2.15-0ubuntu10 is to be installed
Depends: libdevmapper1.02.1 (>= 2:1.02.63) but 2:1.02.48-4ubuntu7 is to be installed
Depends: libsystemd-journal0 (>= 201) but it is not installable
Recommends: aufs-tools but it is not going to be installed
Recommends: cgroupfs-mount but it is not installable or
cgroup-lite but it is not going to be installed
Recommends: git but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
How to solve this error?