Error saying "Failed to request cluster info, will try again" when trying to join the kubernetes cluster

0 votes

I have created the cluster on the master and i've also got the command to execute on the nodes to join the cluster but when i run that command on the nodes, it gives the following output

Running pre-flight checks
[discovery] Trying to connect to API Server "IP_ADDRESS:6443"
[discovery] Created cluster-info discovery client, requesting info from "https://IP_ADDRESS:6443"
[discovery] Failed to request cluster info, will try again: [Get https://IP_ADDRESS:6443/api/v1/namespaces/kube-public/configmaps/cluster-info: Forbidden]

Also I'm trying this on aws

Oct 5, 2018 in Kubernetes by lina
• 8,200 points

1 answer to this question.

+1 vote

I had faced the same error.

Make sure there is a SSH connection between your master and nodes. Just go to your security configurations and make sure you have the following.

answered Oct 5, 2018 by Kalgi
• 51,890 points
Thank you very much. Sent my whole day in this.
Glad it could help :)

Related Questions In Kubernetes

0 votes
1 answer

Code error 403 when trying to access Kubernetes cluster

You get this error because you're getting ...READ MORE

answered Jan 4, 2019 in Kubernetes by Kabeer
0 votes
1 answer

permissions related to AWS ECR

if you add allowContainerRegistry: true, kops will add those permissions ...READ MORE

answered Oct 9, 2018 in Kubernetes by Kalgi
• 51,890 points
0 votes
1 answer

Create LoadBalancer for kubernetes cluster in aws

Hello @Lina, If you're running your cluster on ...READ MORE

answered Oct 8, 2018 in Kubernetes by Kalgi
• 51,890 points
0 votes
1 answer