Building a particular tenant in hybris

0 votes

I have three different tenant present inside the custom folder.

<HYBRIS_HOME>/bin/custom
            |
            |
tenant1  tenant2 tenant3 

If I run ant clean all it builds all three but I only want to build on tenant at a time. Any way I can do this?

Aug 1, 2018 in DevOps & Agile by Atul
• 10,240 points
57 views

1 answer to this question.

0 votes

There isn't an in-built option to only build a particular tenant. The default behavior of hubris builds all extension in localextensions.xml with their dependencies.

But you can try this workaround:

  • you can have several localextensions.xml and switch them with a script
  • you can use ant extensionsxml -Dplatform.extensions="ext1 ext2" -Dplatform.extensionsgen.filename=localextensions.xml to generated the extensions file for your tenant specific extensions
answered Aug 1, 2018 by DareDev
• 6,810 points

Related Questions In DevOps & Agile

+1 vote
2 answers

is it possible to assign a Feature/User Story/Task to a team [Group] in VSTS

In most cases, we would break Work ...READ MORE

answered Oct 11, 2018 in DevOps & Agile by lina
• 8,110 points
830 views
0 votes
2 answers

Running a cron job in a docker conratiner

Let’s create a new file called "crontab" ...READ MORE

answered Aug 7, 2018 in DevOps & Agile by Kalgi
• 42,280 points
4,436 views
0 votes
1 answer

Can I run a program on release failure in TFS?

You can try and do the following ...READ MORE

answered Apr 26, 2018 in DevOps & Agile by ajs3033
• 7,280 points
46 views
0 votes
1 answer
+13 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,380 points
211 views
0 votes
1 answer
+13 votes
2 answers
0 votes
1 answer

TFS shows a / error when building app.

Seems like you haven't set the virtual ...READ MORE

answered Apr 29, 2018 in DevOps & Agile by DareDev
• 6,810 points
35 views