i am getting an error on pycharm while installing packages

0 votes
 ERROR: Command errored out with exit status 1:
     command: 'c:\users\home\desktop\audiobook\venv\scripts\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\home\\AppData\\Local\\Temp\\pip-install-mr3yfoo6\\comty
pes\\setup.py'"'"'; __file__='"'"'C:\\Users\\home\\AppData\\Local\\Temp\\pip-install-mr3yfoo6\\comtypes\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"
'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:\Users\home\AppData\Local\Temp\pip-pip-egg-info-btlrir33'
         cwd: C:\Users\home\AppData\Local\Temp\pip-install-mr3yfoo6\comtypes\
    Complete output (5 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "c:\users\home\desktop\audiobook\venv\lib\site-packages\setuptools\__init__.py", line 8, in <module>
        import _distutils_hack.override  # noqa: F401
    ValueError: source code string cannot contain null bytes
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
Oct 26 in Python by anonymous
• 120 points
53 views

1 answer to this question.

0 votes

Hi, @There,

$ pip install gevent --pre
$ pip install auto-py-to-exe

Explanation: auto-py-to-exe is installable on Python 3.8 on Windows without any issues (this can be verified e.g. by running pip install auto-py-to-exe --no-deps). However, it requires bottle-WebSocket to be installed, which in turn has gevent dependency. the gevent did not release a stable version that offers prebuilt wheels for Python 3.8 yet (this would be 1.5), so pip doesn't pick up prebuilt wheels and tries to build gevent==1.4 from source dist. Installing the prerelease 1.5 version of gevent avoids this.

answered Oct 27 by Gitika
• 48,320 points

Related Questions In Python

0 votes
3 answers

i am installing wordcloud using pip but i am unable to do that ....i am getting the following error

Hi @ Prajwala  All the members here, I ...READ MORE

answered Sep 14 in Python by Richa sharma
2,447 views
0 votes
1 answer

I was written the python program, am getting error message "IndentationError: expected an indented block"

Hi@Thiyagarajan, You have one else block in your ...READ MORE

answered May 27 in Python by MD
• 77,580 points
1,437 views
0 votes
1 answer

I tried to install this pip cryptography in Pycharm but I'm getting an error

Hello @Dilpreet , Have you tried updating pip version? ...READ MORE

answered Aug 4 in Python by Niroj
• 76,540 points
243 views
0 votes
1 answer

Why am I getting a error when I am printing two different data types in python?

different data type is being used. that ...READ MORE

answered Mar 6, 2019 in Python by Mohammad
• 3,210 points
124 views
0 votes
1 answer

Error while installing cv2 module in pycharm

Go to tools -> python console -> ...READ MORE

answered Jun 24, 2019 in Python by Quin
4,860 views
0 votes
0 answers

I am trying to install PyBase64 on my python 3.8. But I end up with the following error:

$ pip install pybase ERROR: Could not find ...READ MORE

Mar 24 in Python by Nishant
• 210 points
385 views
0 votes
1 answer

what is vm options ? I installed Pycharm on my pc but it shows no vm options file found . What should i do please help me to fix it

Hi, @Mushfiqkhantrial, It is important to run pycharm.sh from the bin folder. The VM ...READ MORE

answered Oct 4 in Python by Gitika
• 48,320 points
133 views
0 votes
1 answer

Please Help me About this Pygame Error installing on pip

Hi, @Micheal, Download pygame‑1.9.3‑cp37‑cp37m‑win_amd64. While if you have a 64-bit ...READ MORE

answered Oct 12 in Python by Gitika
• 48,320 points
362 views