I tried to install this pip cryptography in Pycharm but I m getting an error

0 votes

ERROR: Could not find a version that satisfies the requirement cryptography (from versions: none)

Aug 4, 2020 in Python by Dilpreet
• 120 points

recategorized Aug 4, 2020 by Gitika 855 views

1 answer to this question.

0 votes

Hello @Dilpreet ,

Have you tried updating pip version? which python and python-pip versions are you using?

If you are using python 3.x, Please try this commands to update:

sudo pip3 install --upgrade pip

sudo pip3 install virtualenv

Then You can install cryptography with:

$ pip install cryptography

However you can refer this docs

Hope this helps!!
Thank you!!

answered Aug 4, 2020 by Niroj
• 82,680 points

Related Questions In Python

0 votes
3 answers

i am installing wordcloud using pip but i am unable to do that ....i am getting the following error

Hi @ Prajwala  All the members here, I ...READ MORE

answered Sep 14, 2020 in Python by Richa sharma
4,535 views
0 votes
1 answer

i write this python to read dataset into panda data frame but im getting NameError: name 'true' is not defined. Below is the code:

change  def parse(path):   g = gz ...READ MORE

answered Mar 14, 2020 in Python by Abhishek Shingadiya
1,168 views
0 votes
0 answers

I am trying to install pyknow but i get this error

could not find a version that  satisfies ...READ MORE

Mar 4, 2020 in Python by Maria
• 120 points
870 views
0 votes
1 answer

I am trying to install PIL module But I end up with an error :

Hi@Nishant, You can use PILLOW instead of PIL. $ ...READ MORE

answered Apr 6, 2020 in Python by MD
• 95,140 points
9,159 views
0 votes
1 answer
+1 vote
1 answer

Error loading package list:pypi.python.org

You can try doing the following : go ...READ MORE

answered Jan 9, 2019 in Python by ana1504.k
• 7,900 points
5,645 views
+1 vote
4 answers

How to install tkinter in pycharm?

Ya, this is a problem with installing ...READ MORE

answered Apr 3, 2019 in Python by Jishan
44,073 views
0 votes
1 answer