Puppet: Error on executing "systemctl enable puppetserver" command

0 votes
Synchronizing state of puppetserver.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable puppetserver
update-rc.d: error: Permission denied

On trying to enable the Puppetserver service on my ubuntu master i got the following error..How do i resolve it?

Sep 17 in Puppet by Liana
24 views

1 answer to this question.

0 votes

You need root user privileges to execute systemctl commands. 

Try executing the same command as a root user:

sudo systemctl enable puppetserver

This should solve the error for you.

answered Sep 17 by Sirajul
• 30,540 points

Related Questions In Puppet

0 votes
1 answer

need to enable puppet platform on Apt package management system

Log in as root, download the package and ...READ MORE

answered Jul 31 in Puppet by Sirajul
• 30,540 points
30 views
+13 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,380 points
180 views
0 votes
1 answer