Puppet: Error while downloading a module using puppet module install command.

0 votes

I am on Solaris10 machine and trying to install a puppetlabs-apache module using puppet module install command, I am getting the following error:

Error: Could not connect via HTTPS to https://forgeapi.puppetlabs.com Unable to verify the SSL certificate The certificate may not be signed by a valid CA The CA bundle included with OpenSSL may not be valid or up to date

 what's the issue? Why can't I download the module?

Aug 26 in Puppet by Karan
• 6,060 points
18 views

1 answer to this question.

0 votes

This error occurs because there is no CA-cert bundle on Solaris 10 to trust the Forge certificate.

To work around this issue, download the module from the Forge website, and then install the module tarball with the puppet module install command.

This will resolve it!

answered Aug 26 by Sirajul
• 39,540 points
Puppet: How to install a module from a release tarball?

Related Questions In Puppet

0 votes
1 answer

Error while using newrelic class - Puppet

Hey @Harjot, The catalog compiler will look ...READ MORE

answered Feb 14 in Puppet by Ranjan
34 views
0 votes
1 answer

Error while trying to instal mssql tools using puppet

When you use puppet, you don't use ...READ MORE

answered Feb 25 in Puppet by Nandita
141 views
0 votes
1 answer

Install LAMP Stack by creating a new module - Puppet

Hey @Ruth, yes you can set up ...READ MORE

answered Mar 11 in Puppet by Shalaka
37 views
+13 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,380 points
219 views
0 votes
1 answer
0 votes
1 answer

Puppet : Can i install jenkins on a puppet server using Git?

Installing puppet-jenkins is easy. To install via Git, ...READ MORE

answered Aug 9 in Puppet by Sirajul
• 39,540 points
37 views