Puppet module path is not updating.

0 votes

I have a puppet agent which is an ubuntu server on Aws. I added a module path entry to the /etc/puppetlabs/puppet/puppet.conf file. inorder to resolve a :"class not found error".

modulepath=/home/ubuntu/repos/puppet-tests/modules

However, if I run the following command, I am told that the module path(s) haven't changed.

puppet apply --configprint modulepath

I have tried placing the modulepath setting in both the [main] and [agent] sections.what am i missing?

Aug 5 in Puppet by Ryan
10 views

1 answer to this question.

0 votes

The puppet confdir depends on user that executes puppet command. That's why puppet cofiguration will differ for different users.

Execute puppet as a root, or modify puppet config for non root user in ~/.puppetdirectory.

This should do!

answered Aug 5 by Sirajul
• 19,670 points

Related Questions In Puppet

0 votes
1 answer

What is the use of etckeeper-commit-post and etckeeper-commit-pre on Puppet Agent?

Hey @Pallavi,  etckeeper-commit-post: In this configuration file you can ...READ MORE

answered Feb 15 in Puppet by Simran
73 views
0 votes
1 answer
+13 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,380 points
124 views
0 votes
1 answer
0 votes
1 answer

what is the puppet module command?

This command provides an interface for managing ...READ MORE

answered Jul 29 in Puppet by Sirajul
• 19,670 points
15 views