puppet agent --test Error: Could not request certificate: Connection refused - connect(2) for "puppet" port 8140 Exiting; failed to retrieve certificate and waitforcert is disabled

0 votes
I am getting the above error when i'm trying to request sign the certificates. I have configured my server and agent properly and i am able to ping them from the other. where am i going wrong?
Aug 5 in Puppet by Isabelle
38 views

1 answer to this question.

0 votes

In the later versions of puppet we need to enable the pupet server. Check if this is done.

Only starting the puppet server & services will not work we have to enable the server as well. 

Following command is for starting the server :

puppet resource service puppetserver ensure=running

This command is to enable the server.

puppet resource service puppetserver enable=true
answered Aug 5 by Sirajul
• 25,220 points

Related Questions In Puppet

0 votes
1 answer
+13 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,380 points
147 views
0 votes
1 answer