Multichain Resource temporarily unavailable error

+1 vote

I am getting the following error while using multichain. 

$multichaind chain8 -daemon
Multichain 1.0.3 Daemon (latest protocol 10009)
Starting up node...
IO error: lock /home/edureka/.multichain/chain8/permissions.db/LOCK: Resource temporarily unavailable

How can I solve this?

Jul 10, 2019 in Blockchain by Yashita
297 views

1 answer to this question.

0 votes

The command you have executed is used to create a "genesis block" for the first time when the chain is created.

It seems you have already executed the command in the past. Therefore it is throwing an error because genesis block is only initiated once in its lifetime. 

You can directly execute the command multichain-cli chain8 to interact with multichain.

If you want to re-create the chain8 from scratch, you need to delete the instance of chain8 which is already present in your machine.

Please execute the following command to delete the older instance and create a new instance:

cd ~/.multichain && sudo rm -rf chain8

Now exit your terminal.

Open a new Terminal and execute the following command:

multichain-util create chain8  (for creating a chain)
multichaind chain8 -deamon (for creating a genesis block)
answered Jul 10, 2019 by Olivia

Related Questions In Blockchain

0 votes
1 answer

AWS multichain network, "Couldn't connect to the seed node" error

The error says "please check multichaind is ...READ MORE

answered Jul 9, 2018 in Blockchain by slayer
• 29,310 points
713 views
0 votes
1 answer

How to solve “Error: Expected a Resource or Concept”?

There are few errors in code. I ...READ MORE

answered Jul 31, 2018 in Blockchain by slayer
• 29,310 points
696 views
0 votes
1 answer

Multichain installation error

Please follow the below steps to install ...READ MORE

answered May 22, 2019 in Blockchain by Wasim
204 views
0 votes
1 answer

How can i read headers of blockchain in multichain?

You could use a recent feature known ...READ MORE

answered Mar 26, 2018 in Blockchain by Perry
• 17,100 points
339 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
1,041 views
0 votes
1 answer
0 votes
3 answers

Hyperledger fabcar sample fabric error: sendPeersProposal - Promise is rejected: Error: Connect Failed

Open the datasources.json file and replace the grpcs:// with grpc://. This solution worked ...READ MORE

answered Apr 30, 2019 in Blockchain by Reshma
1,788 views
+1 vote
4 answers

Installing Nodejs: sh: node: command not found error

You have to first install nodejs and ...READ MORE

answered Oct 22, 2018 in Blockchain by Omkar
• 69,190 points
22,939 views
webinar REGISTER FOR FREE WEBINAR X
Send OTP
REGISTER NOW
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP