Hyperledger fabcar sample fabric error: sendPeersProposal - Promise is rejected: Error: Connect Failed

0 votes

I am getting the following error when I am trying to install hyperledger and run chaincode. I am following the steps from here

error: [client-utils.js]: sendPeersProposal - Promise is rejected: Error: Connect Failed

while running the query.js. enter image description hereI have following active docker runningenter image description here

Jul 19, 2018 in Blockchain by charlie_brown
• 7,710 points
721 views

3 answers to this question.

0 votes

The problem is with the connection. 

First, find out the IP address of the system:

$ ifconfig

Then replace localhosts in query.js with IP that you found with the previous command

Example:

@@ -12,7 +12,7 @@ var options = {
     user_id: 'PeerAdmin',
     channel_id: 'mychannel',
     chaincode_id: 'fabcar',
   network_url: 'grpc://<IP address>:7051',
};

answered Jul 19, 2018 by ariaholic
• 7,320 points

Hi. I am new to Linux and when I run ifconfig, I am getting 2 IP address, which should I use?

Hi @Rashmi. A system can have more than one IP address depending on the number of interfaces. Could mention the name of the interface or maybe share a screenshot?

I think I have 2 interfaces. One is named lo and the other is named eth0. Which should I use?

lo is a loopback address and eth0 is ethernet. Use the IP address for the interface eth0.

0 votes

Try to install nom first and then run node query.js.

$ npm install
answered Apr 30 by Rajat

When I run this, I am getting the following error:

warning :npm WARN fabcar@1.0.0 No repository field.
0 votes

Open the datasources.json file and replace the grpcs:// with grpc://.

This solution worked for me. 

answered Apr 30 by Reshma

Related Questions In Blockchain

0 votes
1 answer

Hyperledger Fabric:Promise is rejected:Error:Failed to deserialize creator identity,The supplied identity is not valid.

 This error happens because basic-network/docker-compose.yaml has CA ...READ MORE

answered Nov 14, 2018 in Blockchain by Omkar
• 67,120 points
178 views
0 votes
1 answer

sendProposal - timed out after:45000, sendPeersProposal - Promise is rejected: Error: REQUEST_TIMEOUT

You could simply replace --net=bridge with --net=artifacts_default in your DockerFile.  I used ...READ MORE

answered Jul 26, 2018 in Blockchain by Perry
• 17,010 points
270 views
0 votes
1 answer
+2 votes
3 answers

Hyperledger Fabric: Peer Connection error: Failed obtaining connection: Could not connect to any of the endpoints.

 You can extend your /etc/hosts file and make orderer.example.com domain name ...READ MORE

answered Nov 13, 2018 in Blockchain by Omkar
• 67,120 points
634 views
0 votes
1 answer
0 votes
1 answer

Invalid Batch or signature in Savtooth

This will solve your problem import org.apache.commons.codec.binary.Hex; Transaction txn ...READ MORE

answered Aug 1, 2018 in Blockchain by digger
• 27,620 points
54 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
104 views
0 votes
1 answer

Where can I find the reference format for crypto-config.yaml and configtx.yaml Hyperledger Fabric files?

The sample config files in the Hyperledger Fabric main ...READ MORE

answered Jun 27, 2018 in Blockchain by ariaholic
• 7,320 points
346 views