Nginx: 502 Bad Gateway error after deploying redmine in kubernetes cluster.

+1 vote

I tried to deploy redmine in kubernetes cluster (containing 1 master and 2 workers) through this helm chart "https://gitlab.com/kanzari.1993/redmine" with nginx ingress controller enabled, the deployment done with success but when I tried to access the application through the name of the host mentioned in the ingress.yaml file I get this warning: "502 Bad Gateway nginx / 1.17.0" on the other hand all the pods are in "running" state.

Do you have an idea about how to solve this problem?

I think the problem is coming from the deployed application itself "redmine" there is the outputs to explain more the situation.

Jul 5 in Kubernetes by Mehrez
• 130 points
151 views

As you've mentioned

all the pods are in "running" state.

But the third pod is not running. It's in CrashLoopBackOff state. 

Yeah do u have an idea about how to fix that problem?

Have a look at this for Node in CrashLoopBackOff:

https://www.edureka.co/community/34720/pods-stuck-in-crashbackloopoff-state?

Also @Mehrez, this seems like the redmine issue to me. Did you try deploying it without the ingress?
No I try to deploy it w/ ingress enabled!
You have pulled the docker image for redmine as shown in one of the screenshots.

Pulling image "docker.io /bitnami/redmine...."

Try to run this docker image without kubernetes, without ingress. If it works you know the issue is with the ingress.

1 answer to this question.

+1 vote
I have fixed the problem! the issue was in the image itself it restarts periodically which means the pod failed to create the container!
answered Jul 12 by Mehrez Kanzari
Whoa. And why was that happening??
How did you fix the image issue?

Related Questions In Kubernetes

0 votes
2 answers

DNS does not resolve with NGINX in Kubernetes

adding to @kalgi's answer Using just the hostname ...READ MORE

answered Aug 30, 2018 in Kubernetes by Nilesh
• 6,900 points
409 views
0 votes
1 answer

Error saying "The specified bucket does not exist" in kubernetes

Bucket is created in another region. Looks like ...READ MORE

answered Aug 31, 2018 in Kubernetes by Kalgi
• 39,150 points
232 views
0 votes
1 answer
0 votes
1 answer

oci runtime error while running kubernetes on rancher cluster

You need to switch Docker to 1.12.x; ...READ MORE

answered Sep 6, 2018 in Kubernetes by Kalgi
• 39,150 points
83 views
0 votes
5 answers
0 votes
1 answer
0 votes
1 answer
0 votes
3 answers

Nginx reverse proxy URL getting rewritten

 take a look at  nginx.ingress.kubernetes.io/app-root and  nginx.ingress.kubernetes.io/rewrite-target annotations(https://kubernetes.github.io/.../nginx.../annotations/). I'm not sure ...READ MORE

answered Mar 6 in Kubernetes by Madhu
548 views