Unable to find the TargetArguments path While configuring dot cover in VSTS

+3 votes

I installed resharper CL in my build server and have added CL task in my VSTS build profile:

Build profile

In this project, I am using xUnit test project. My main problem is target executable path. I tried installing xUnit as it is VS extension. But how can I use xUnit as target executable?

Following is the command line I want to use:

dotcover analyse  /TargetExecutable={Path to Xunit}"   /TargetArguments= $(Build.SourcesDirectory)+"\xxxxxx.AD.UnitTest\bin\Release\VonExpy.AD.UnitTest.dll"   /Output="AppCoverageReport.html"   /ReportType="HTML"
Mar 27, 2018 in DevOps & Agile by Atul
• 10,200 points
56 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

For your unable to find the TargetArguments path issue, the parameter value for TargetArguments is not correct

Change it to: /TargetArguments="$(Build.SourcesDirectory)\xxxxxx.AD.UnitTest\bin\Release\VonExpy.AD.UnitTest.dll"

Now for the xUnit test, according to this thread: Error encountered when running dotcover console runner using xunit as the target executable, you hsould use xunit.console.exe in xunit.runner.console package.

answered Mar 27, 2018 by ajs3033
• 7,040 points
Totally agree with this, it has worked for me..

Related Questions In DevOps & Agile

+1 vote
2 answers

is it possible to assign a Feature/User Story/Task to a team [Group] in VSTS

In most cases, we would break Work ...READ MORE

answered Oct 11, 2018 in DevOps & Agile by lina
• 8,100 points
422 views
+13 votes
2 answers
0 votes
1 answer

Error: Unable to access elasticsearch in docker for windows

This is simple, just follow the below ...READ MORE

answered Sep 3, 2018 in DevOps & Agile by Sophie may
• 9,090 points
25 views
0 votes
1 answer
+5 votes
7 answers

Docker swarm vs kubernetes

Swarm is easy handling while kn8 is ...READ MORE

answered Aug 27, 2018 in Docker by Mahesh Ajmeria
632 views
+13 votes
2 answers
+5 votes
2 answers

Steps to Call Python method in BuildBot

To run python code, you must write ...READ MORE

answered Mar 27, 2018 in DevOps & Agile by ajs3033
• 7,040 points

edited Oct 12, 2018 by Kalgi 192 views
0 votes
1 answer

unable to build .Net project using NUGet

you just need the developer pack for ...READ MORE

answered Apr 3, 2018 in DevOps & Agile by ajs3033
• 7,040 points
105 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.