Docker for windows: Eval command not found

0 votes

Eval command does not exist in Windows.

How do I run this command on Docker for Windows?

C:\Users\mary> eval "$(docker-machine env my-default)"

I can run this command just fine from Git Bash but I'm curious why the Docker tutorial says to run this command from the Windows command prompt.

Oct 1, 2018 in Docker by Sophie may
• 9,330 points
324 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

Follow the below commands to configure your shell terminal:

docker-machine env --shell cmd my-default
FOR /f "tokens=*" %i IN ('docker-machine env --shell cmd my-default') DO %i

After successfully running the above commands you can run any docker command from the shell/cmd terminal.

answered Oct 1, 2018 by Tyrion anex
• 8,280 points

Related Questions In Docker

0 votes
3 answers

Error: docker command not found

If you're using Docker as an administrator, ...READ MORE

answered Apr 29 in Docker by Naina
977 views
0 votes
1 answer

Error: Docker for Windows not working

The following worked for me: Download VirtualBox 5.03  Reboot ...READ MORE

answered Aug 13, 2018 in Docker by Sophie may
• 9,330 points
44 views
0 votes
1 answer
0 votes
6 answers

docker: executable file not found in $PATH

file not found in $PATH READ MORE

answered May 9 in Docker by anonymous
5,599 views
0 votes
1 answer
0 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 56,140 points
79 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.