Error docker command not found

0 votes

I tried installing Docker on ubuntu but I end up getting the “docker command not found” error.

sudo apt get install docker

After installation when I run docker it gives me the following error:

The program 'docker' is currently not installed. You can install it by typing: sudo apt-get install docker

Is there a simple fix to this problem?

Jul 31, 2018 in Docker by Tyrion anex
• 8,700 points

3 answers to this question.

0 votes

You have to use curl, follow the commands below:

sudo curl -sSL http://getdocker/ | sh

This will execute a code that installs docker.

 Note the last part of the script:

If you would like to use Docker as a non-root user, you should now consider adding your user to the "docker" group with something like:
sudo usermod -aG docker user
Remember that you will have to log out and back in for this to take effect!

Then, update Docker run:

sudo apt-get update && apt-get upgrade

and make sure that you use instead of docker.

sudo apt-get install
answered Aug 1, 2018 by Sophie may
• 10,610 points
0 votes

Add the following in your path environment:

C:\Program Files\Docker Toolbox
answered Apr 29, 2019 by wazir
This did not work for me!
Did you restart your docker after adding the path?
No.. I'll try that and let you know
Ohh thanks, it worked!
0 votes
If you're using Docker as an administrator, then using it as it is(without adding path) should also work!
answered Apr 29, 2019 by Naina

Related Questions In Docker

0 votes
1 answer

Error: docker-machine command not found

Hey @Ruby, You can indeed spin-up multiple ...READ MORE

answered Jul 4, 2019 in Docker by Sirajul
• 59,230 points
0 votes
2 answers

Docker for windows: Eval command not found

I use the cmder console emulator. For the ...READ MORE

answered Aug 29, 2020 in Docker by Pistle
• 1,000 points

edited Aug 30, 2020 by Gitika 6,736 views
0 votes
1 answer
+2 votes
1 answer
+2 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 58,090 points
0 votes
1 answer

Docker image of maven returns this error - could not create local repository

Instead of mounting the root/.m2 folder to ...READ MORE

answered Aug 10, 2018 in Docker by Sophie may
• 10,610 points
0 votes
1 answer

Error: Docker for Windows not working

The following worked for me: Download VirtualBox 5.03  Reboot ...READ MORE

answered Aug 14, 2018 in Docker by Sophie may
• 10,610 points
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP