Docker for windows: Eval command not found

0 votes

Eval command does not exist in Windows.

How do I run this command on Docker for Windows?

C:\Users\mary> eval "$(docker-machine env my-default)"

I can run this command just fine from Git Bash but I'm curious why the Docker tutorial says to run this command from the Windows command prompt.

Oct 1, 2018 in Docker by Sophie may
• 10,100 points
2,653 views

2 answers to this question.

0 votes

Follow the below commands to configure your shell terminal:

docker-machine env --shell cmd my-default
FOR /f "tokens=*" %i IN ('docker-machine env --shell cmd my-default') DO %i

After successfully running the above commands you can run any docker command from the shell/cmd terminal.

answered Oct 1, 2018 by Tyrion anex
• 8,560 points
0 votes

I use the cmder console emulator. For the most part, I followed the docker docs for setting up from the windows 10 command prompt, except for the eval statement. When I attempted to run the eval statement described in the docs, I was prompted to run a different command instead (below), and it successfully activated my machine. MY-MACHINE-HERE should be the name of the machine you will have already created in an earlier step.

@FOR /f "tokens=*" %i IN ('docker-machine env MYMACHINEHERE') DO @%i

Hope This Will Help

Best Regards


answered Aug 29 by Pistle
• 1,000 points

edited Aug 29 by Gitika

Related Questions In Docker

0 votes
3 answers

Error: docker command not found

If you're using Docker as an administrator, ...READ MORE

answered Apr 29, 2019 in Docker by Naina
8,793 views
0 votes
1 answer

Error: Docker for Windows not working

The following worked for me: Download VirtualBox 5.03  Reboot ...READ MORE

answered Aug 13, 2018 in Docker by Sophie may
• 10,100 points
499 views
0 votes
1 answer
0 votes
1 answer

Error: docker-machine command not found

Hey @Ruby, You can indeed spin-up multiple ...READ MORE

answered Jul 4, 2019 in Docker by Sirajul
• 58,130 points
4,743 views
+2 votes
1 answer
+2 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 57,700 points
855 views