Could not find default credentials

0 votes

finished gloud init, I followed instructions and did:

gcloud container clusters get-credentials cluster-1 --zone europe-west1-c --project whatever

And then:

kubectl proxy

But I got the following error message:

error: google: could not find default credentials. See https://developers.google.com/accounts/docs/application-default-credentials for more information.
Aug 30, 2018 in Kubernetes by Hannah
• 18,070 points
743 views

1 answer to this question.

0 votes

Use

gcloud auth application-default login

to login for application default creadentials 

answered Aug 30, 2018 by Kalgi
• 51,890 points

Related Questions In Kubernetes

0 votes
1 answer
0 votes
1 answer

Error from server (NotFound): the server could not find the requested resource

Hi@akhatr, The following error might indicate that something ...READ MORE

answered Jul 15 in Kubernetes by MD
• 42,420 points
76 views
0 votes
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17, 2019 in Others by anonymous
7,621 views
+4 votes
1 answer

Installing Web UI (Dashboard):kubernetes-dashboard on main Ubuntu 16.04.6 LTS (Xenial Xerus) server

Follow these steps: $ kubeadm reset $ kubeadm init ...READ MORE

answered Apr 11, 2019 in Kubernetes by Kalgi
• 51,890 points

reshown Apr 12, 2019 by Kalgi 2,241 views
0 votes
2 answers

Error saying “Error from server (NotFound): the server could not find the requested resource”

official Documentation says: A client should be skewed ...READ MORE

answered Sep 19, 2018 in Kubernetes by Nilesh
• 6,970 points
2,272 views
0 votes
3 answers

Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) while setting up kubernetes

Execute these three commands: sudo rm /var/lib/apt/lists/lock sudo rm ...READ MORE

answered Nov 27, 2018 in Kubernetes by Maverick
• 10,820 points
387 views