Session app error while installing APK

0 votes

I am having tons of difficulty in importing a project written on Android Studio 1.1 into the Android Studio 2.1.2 process. I keep getting this error whenever the gradle is built before testing the app on a tablet. Below is a screen shot of the error. Does anyone know what the problem could be? I have tried adb kill-server followed by adb start-server as well as some other gradle versions compatible with the project. Other than this, I have not been able to find many more suggested solutions to the problem ("session 'app': error installing APK").

Additionally, I have tried uploading a basic Hello World project which successfully built the gradle.

Error message from Grable Build:

Initial Error Message

Second set of Errors

Feb 22 in Others by Rahul
• 9,680 points

1 answer to this question.

0 votes
In order to overcome this problem, start with disconnecting all devices connected to System/Close all emulators running on System. Then Turn Off Instant Run feature from settings. Perform a clean build and then Turn ON Instant Run feature from settings. Perform a clean build by connecting your device and ensure it is online and then Run the Project by selecting the device/emulator. Please keep in mind that you should not have different instances of Android Debug Bridge(adb) running on the system. If what you are using is Genymotion then make sure that you use the custom sdk path mentioned in the Genymotion settings which you mentioned in the settings of Android Studio.

Follow all the steps and I am sure you will get the issue fixed.
answered Feb 22 by Aditya
• 7,660 points

Related Questions In Others

0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17, 2019 in Others by anonymous
0 votes
1 answer

The uploaded file exceeds the upload_max_filesize directive in php.ini error while uploading plugin

After looking at your ERROR, it seems ...READ MORE

answered Feb 8 in Others by Soham
• 9,670 points
0 votes
1 answer

Running docker on Android

According to the documentation, the Android kernel is ...READ MORE

answered Aug 1, 2018 in Docker by Kalgi
• 52,350 points
0 votes
1 answer

Task Canceled Exception while invoking AWS Lambda

I'm guessing either the TaskCanceledException instance is ...READ MORE

answered Sep 19, 2018 in AWS by Priyaj
• 58,100 points
0 votes
1 answer

Is there a way to run Python on Android?

YES! An example via Matt Cutts via SL4A -- "here’s ...READ MORE

answered Sep 19, 2018 in Python by Priyaj
• 58,100 points
0 votes
1 answer

How can we get the current location in Android?

First you need to define a LocationListener to handle ...READ MORE

answered Sep 25, 2018 in Java by Parth
• 4,630 points
0 votes
1 answer

TCPDF ERROR: Some data has already been output, can't send PDF file

To answer your question, do add the ...READ MORE

answered Feb 16 in Others by Aditya
• 7,660 points
0 votes
1 answer
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP