Install RStudio on AWS EC2 instance

0 votes

I managed to create an EC2 instance Amazon Linux AMI 2017.09.1 (randomly chosen) on Amazon Web Services (AWS). I can send and receive files from my local desktop to AWS properly.

Now I would like to install R (RStudio Server) on AWS. When searching for an answer, I found the script below that is to be written into Putty:

# install R base

$ sudo yum install r-base

#install RStudio-Server 1.1.442

$ sudo yum install gdebi-core

$ wget https://download2.rstudio.org/rstudio-server-1.1.442-amd64.deb

$ sudo gdebi rstudio-server-1.1.442-amd64.deb
#add user(s)

useradd username

echo username:password | passwordtest

But the answer I get each time is: "No package r-base available" or also "No package gdebi-core available".

Are they some prerequisite steps that I am missing?

Jul 27, 2018 in AWS by bug_seeker
• 15,310 points
160 views

1 answer to this question.

0 votes

Amazon Linux AMI 2017.09.1 is based on Centos 6 and the step you got is for Ubuntu(gdebi is an Ubuntu installer), Here are the steps from the official documentation.

$ sudo yum install R

$ wget https://download2.rstudio.org/rstudio-server-rhel-1.1.442-x86_64.rpm

$ sudo yum install rstudio-server-rhel-1.1.442-x86_64.rpm

You can try this it worked out fine for me. Hope this help.

answered Jul 27, 2018 by Priyaj
• 56,160 points

Related Questions In AWS

0 votes
1 answer

How to install redis on AWS Micro instance?

Maybe you can spin up an EC2 ...READ MORE

answered Jan 30 in AWS by Archana
• 5,480 points
26 views
0 votes
1 answer

How to install Python on my ec2 instance?

EC2 on linux machine currently supports python3.4 ...READ MORE

answered Mar 27 in AWS by Ritesh
152 views
+2 votes
2 answers

Is it possible to ping AWS EC2 instance

Start by adding a new EC2 security group inbound ...READ MORE

answered Apr 9, 2018 in AWS by hemant
• 5,750 points
311 views
+13 votes
2 answers
0 votes
1 answer
+1 vote
2 answers

How do I run python script on aws EC2 instance(ubuntu)?

I believe that you are using the ...READ MORE

answered Apr 17, 2018 in AWS by Cloud gunner
• 4,260 points
1,626 views
0 votes
1 answer

Getting ORA-01882: timezone region not found with Oracle UCP, on aws ec2 instance?

You can pass command line argument -Duser.timezone=<Database Time ...READ MORE

answered Oct 3, 2018 in AWS by Priyaj
• 56,160 points
256 views