Cloning the Git Repository on Eclipse (Transport Error)

+1 vote

I have a web application on Bluemix and linked with a git repository.

I'm working on Eclipse and made some changes on the project. Now, I have the last version of the project in Local and Bluemix side and need to update the repository.

As a first step, I am trying to clone the Git repository (on Eclipse). After I fill the URI and authentication fields, I am getting the error that is shown below. I can pass over SSL error by setting http.sslVerify=false but cannot solve the others.

org.eclipse.egit.ui
 Error
 Thu Apr 23 12:46:33 EEST 2015
 https://hub.jazz.net/git/***/***: authentication not supported
 org.eclipse.jgit.api.errors.TransportException: https://hub.jazz.net/git/***/***: authentication not supported
     at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:223)
     at org.eclipse.jgit.api.LsRemoteCommand.call(LsRemoteCommand.java:159)
     at org.eclipse.egit.core.op.ListRemoteOperation.run(ListRemoteOperation.java:99)
     at org.eclipse.egit.ui.internal.clone.SourceBranchPage$8.run(SourceBranchPage.java:34)
     at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
 Caused by: org.eclipse.jgit.errors.TransportException: https://hub.jazz.net/git/***/***: authentication not supported
     at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:494)
     at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:309)
     at org.eclipse.jgit.api.LsRemoteCommand.execute(LsRemoteCommand.java:202)
     ... 4 more
Jul 23, 2018 in Git & GitHub by Hannah
• 14,080 points
1,566 views
Try changing the URL.
Yes I did, it did not work!

Are you able to clone the repo from command line Git?

Yes, I have successfully cloned it using command line Git. But what I do not understand is why am I not able to clone is using Eclipse. 

3 answers to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
+1 vote
Best answer
File/Import...
Select dialog
* Git/Projects from Git
* click next
Select Repository Source dialog
* Clone URI
* click next
Source Git Repository dialog
* from Settings page (e.g. https://hub.jazz.net/project/you/yourproject/settings/general)
* copy the Git URL e.g. https://hub.jazz.net/git/you/yourproject
(Host and Repository Path should populate)
* populate User and Password with your IBM ID
* click next
Branch Selection dialog
* (master should be selected)
* click next
Local Destination dialog
* select a local destination
* click next
Select a wizard to use for importing projects dialog
* (Import existing projects should be selected)
* click finish

Try this… it worked for me

answered Jul 23, 2018 by Kalgi
• 36,690 points

selected May 7 by Vardhan
0 votes

Try installing TortoiseGit, execute a few commands and then try again with Eclipse. Might work, not sure. I read this somewhere.

answered Apr 24 by Nilay
0 votes

Check if you've switched on two-factor authentication ON in Git. If you have then when you connect from browser it should authenticate properly and connect. But when you do it from eclipse it only checks normal credentials and fails to authenticate.

answered May 6 by Garima
Change the protocol from https to http while cloning the repository from git .This worked for me. I faced the same problem and got resolved by doing this.
I got the same error. I'll try this and let you know. Thanks

Related Questions In Git & GitHub

0 votes
1 answer
0 votes
1 answer

How to view the nested workflow of a local git repository?

The ‘git log’ command is your closest ...READ MORE

answered Jul 4, 2018 in Git & GitHub by Sophie may
• 9,330 points
44 views
0 votes
1 answer

How to solve the ‘Git commit -a error’?

This happens when no editor is set. ...READ MORE

answered Jul 5, 2018 in Git & GitHub by Tyrion anex
• 8,280 points
31 views
0 votes
1 answer
+13 votes
2 answers
0 votes
1 answer
+1 vote
4 answers

GIT plugin in jenkins not able to connect to GIT repository

This looks like a git configuration issue, ...READ MORE

answered Oct 25, 2018 in Git & GitHub by Alia
916 views
0 votes
1 answer

gerrit-cherry-pick:fatal: 'origin' does not appear to be a git repository

The user account making that command does ...READ MORE

answered Aug 13, 2018 in Git & GitHub by Kalgi
• 36,690 points
141 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.