AWS CloudFront error "InvalidViewerCertificate"

0 votes

I am trying to update an Amazon CloudFront distribution and I edn up with the following error:

InvalidViewerCertificate

How do I get rid of this?

Oct 16 in AWS by Hannah
• 16,420 points
16 views
Can you please describe the error better.

To be precise, this the exact error:

The specified SSL certificate doesn't exist, isn't in us-east-1 region, isn't valid, or doesn't include a valid certificate chain.

1 answer to this question.

0 votes

The error clearly mentions that the certificate is either not in the correct region or it isn't valid. Make sure you meet the below two criteria:

  • The certificate must be imported in the US East (N. Virginia) Region.
  • The certificate must be 2048 bits or smaller.
answered Oct 16 by Tanmay

Related Questions In AWS

0 votes
1 answer

502 Bad Gateway Error in CloudFront AWS

To resolve this you have 2 option.    Enable ...READ MORE

answered Sep 6, 2018 in AWS by Priyaj
• 56,920 points
690 views
0 votes
1 answer

AWS Cloudtrail API for Go SDK showing an error mesage.

You  must add S3 Policy in your ...READ MORE

answered Jun 27, 2018 in AWS by Flying geek
• 3,160 points
171 views
0 votes
1 answer

A strange spark ERROR on AWS EMR

Those warning messages can be suppressed by ...READ MORE

answered Jul 13, 2018 in AWS by Flying geek
• 3,160 points
77 views
0 votes
1 answer
0 votes
1 answer

CloudFront version API - AWS

Hi @Hannah,  1. Enable CloudTrail logging for your ...READ MORE

answered Oct 16 in AWS by Tanmay
19 views