Python: UnicodeDecodeError: "utf-8" codec can"t decode byte 0xa0 in position 10: invalid start byte

+2 votes

Unable to import this file it shows an error. My code was:

import pandas as pd
a = pd.read_csv("filename.csv")
Jul 11, 2019 in Python by Yadu

1 answer to this question.

+5 votes
Best answer

You have to use the encoding as latin1 to read this file as there are some special character in this file, use the below code snippet to read the file. Try this:

import pandas as pd
answered Jul 11, 2019 by Ritu

selected Dec 11, 2019 by Kalgi
Thank you. Worked well for me ....
Glad to hear it :)

Please upvote.

thanks. it worked. 

encoding='latin1' part solved my problem.
thanks worked well
Why does it work ?
Hey guys, how's the corona Quarantine going on? You guys working from home too?
Hey, @Book

It will help if you could just elaborate on your doubt.
Thank you..:) bro
>>> file = open('policydocs/policy/0_policy_Test Backoffice.pdf', encoding='latin1')
>>> result = k.set_contents_from_file(file)
Traceback (most recent call last):
  File "<console>", line 1, in <module>
  File "D:\treatufair\venv\lib\site-packages\boto\s3\", line 1307, in set_contents_from_file
    self.send_file(fp, headers=headers, cb=cb, num_cb=num_cb,
  File "D:\treatufair\venv\lib\site-packages\boto\s3\", line 760, in send_file
    self._send_file_internal(fp, headers=headers, cb=cb, num_cb=num_cb,
  File "D:\treatufair\venv\lib\site-packages\boto\s3\", line 957, in _send_file_internal
    resp = self.bucket.connection.make_request(
  File "D:\treatufair\venv\lib\site-packages\boto\s3\", line 667, in make_request
    return super(S3Connection, self).make_request(
  File "D:\treatufair\venv\lib\site-packages\boto\", line 1070, in make_request
    return self._mexe(http_request, sender, override_num_retries,
  File "D:\treatufair\venv\lib\site-packages\boto\", line 939, in _mexe
    response = sender(connection, request.method, request.path,
  File "D:\treatufair\venv\lib\site-packages\boto\s3\", line 895, in sender
    raise provider.storage_response_error(
boto.exception.S3ResponseError: S3ResponseError: 400 Bad Request
<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>BadDigest</Code><Message>The Content-MD5 you specified did not match what we received.</Message><ExpectedDigest>4a5e3dabb8dd3747f239ddf71050f327</ExpectedDigest><
>>> file = open('policydocs/policy/0_policy_Test Backoffice.pdf', encoding="utf-8")

Thank you. it worked for me too.
Thanks a million. I've been to YouTube and Google searching for a way out.
worked for me also thanks
OMG! Thank you so much. I was stuck on this for a while!! :D
Thank you!!! that additional encoding='latin1' entirely fixes this issue

Related Questions In Python

0 votes
0 answers

utf-8' codec can't decode byte 0xa0 in position 10: invalid start byte

my code import wordcloud import numpy as np from matplotlib ...READ MORE

Mar 29 in Python by anonymous
• 120 points
0 votes
2 answers
0 votes
1 answer

UnicodeDecodeError: 'utf-8' codec can't decode byte 0x89 in position 0: invalid start byte

Hi, @hala, Regarding your query, you can go ...READ MORE

answered Jun 29 in Python by Niroj
• 56,800 points
0 votes
2 answers

UnicodeDecodeError: 'utf-8' codec can't decode byte 0x8b in position 1: invalid start byte

Hey,  @Himanshu. It's still most likely gzipped data. ...READ MORE

answered Jul 27 in Python by Gitika
• 36,530 points
+1 vote
2 answers

how can i count the items in a list?

Syntax :            list. count(value) Code: colors = ['red', 'green', ...READ MORE

answered Jul 6, 2019 in Python by Neha
• 330 points

edited Jul 8, 2019 by Kalgi 1,337 views
0 votes
0 answers
+4 votes
6 answers
0 votes
1 answer
+2 votes
1 answer

UnicodeDecodeError: "utf-8" codec can't decode byte in position : invalid start byte

You have to use the encoding as latin1 ...READ MORE

answered Jul 23, 2019 in Python by Kunal