Namenode stops automatically after a while when started Hadoop.

0 votes

I have installed Hadoop, but after installation when I used jps command to see all Hadoop daemons are running or not, it worked. But I had to shut my system for some stuffs and again when I run the command again its showing all the daemons accept Namenode.

I have already checked with both these command start-all.sh and start-dfs.dh. Still its not working, can anyone give solution to this error?

Jun 17 in Big Data Hadoop by Janosh
31 views

1 answer to this question.

0 votes

Hi,

You can follow these steps which can solve your issue:

  • Delete all the files from the temporary folder: 
rm -Rf <tmp dir>  (my was usr/edureka/hadoop/tmp)
  • Forget the Namenode:

bin/hadoop namenode -format
  • Start all process again:

bin/start-all.sh

I hope it will work.

 

answered Jun 17 by Gitika
• 25,360 points

Related Questions In Big Data Hadoop

0 votes
1 answer

After installing Hadoop on Windows7, NameNode failed to start

You need to install Hadoop winutils to ...READ MORE

answered May 3, 2018 in Big Data Hadoop by Shubham
• 13,310 points
2,366 views
0 votes
1 answer

What happend while formatting hadoop namenode?

Basically, NameNode is the master daemon that ...READ MORE

answered May 3, 2018 in Big Data Hadoop by Ashish
• 2,630 points
42 views
0 votes
1 answer
0 votes
1 answer

Hadoop Mapreduce word count Program

Firstly you need to understand the concept ...READ MORE

answered Mar 16, 2018 in Data Analytics by nitinrawat895
• 10,710 points
3,344 views
0 votes
10 answers

hadoop fs -put command?

put syntax: put <localSrc> <dest> copy syntax: copyFr ...READ MORE

answered Dec 7, 2018 in Big Data Hadoop by Aditya
16,579 views
0 votes
1 answer

Hadoop dfs -ls command?

In your case there is no difference ...READ MORE

answered Mar 16, 2018 in Big Data Hadoop by kurt_cobain
• 9,260 points
1,210 views
0 votes
1 answer