Failed to mkdir while creating a handler directory - Ansible

0 votes

I am trying to install phpDocumentor using pear and when I run

pear install phpdoc/phpdocumentor

I get the following error

ERROR: failed to mkdir /var/www/phpDocumentor/ansible/roles/phpdocumentor.environment/handlers
Mar 14, 2019 in Ansible by Ali

1 answer to this question.

0 votes
Hey @Ali, try running it as a root user and let me know if it works.
answered Mar 14, 2019 by Bob
Hey @Bob, thanks for a quick response. Running the command as root also did not help, I get the same error.

I had got a similar issue. I uninstalled pear and installed it again and it started working. I still do not know the reason.

Related Questions In Ansible

0 votes
1 answer
+1 vote
3 answers
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 27, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
+2 votes
1 answer
0 votes
1 answer

Ansible task to know if a path exists and if its a directory

Hi @Nisha, use the stat module provided ...READ MORE

answered Apr 2, 2019 in Ansible by Alok
0 votes
1 answer

Is there a way to recover lost Ansible Vault password?

Hey @Sridhar, There is no way to ...READ MORE

answered Jan 29, 2019 in Ansible by Akthia