Error saying "Invalid input (privileged mode required)" - Ansible

0 votes

I'm trying to execute a very simple playbook on Ansible but I keep getting the following error:

Invalid input (privileged mode required)

Where am I going wrong?

Mar 6 in Ansible by Laksha
19 views

1 answer to this question.

0 votes

The task that generated this error requires to enable mode to succeed

To set enable mode for a specific task, add become at the task level:

- name: Gather facts (eos)
  eos_facts:
    gather_subset:
      - "!hardware"
  become: yes
  become_method: enable
answered Mar 6 by Yogesh

Related Questions In Ansible

+1 vote
1 answer
0 votes
1 answer

Error saying "KeyError: 'ApiVersion'" - Ansible

The reason behind this error is that ...READ MORE

answered Jan 8 in Ansible by Sasha
13 views
0 votes
1 answer
0 votes
1 answer
+13 votes
2 answers
0 votes
1 answer
0 votes
1 answer

Error saying "Failed to find required executable npm in paths"

Hey @Thomas,  Seems like those extra paths have ...READ MORE

answered Jan 10 in Ansible by Naina
99 views
0 votes
1 answer

Remote host throwing error saying "Permission Denied" - Ansible

Hey @Patrick, Change the path of Ansible's remote_tmp ...READ MORE

answered Jan 16 in Ansible by Cerci
95 views