geth attach command showing error: bind: address already in use

0 votes

When I run 

geth attach 

command, I am getting this following error:

Fatal: Error starting protocol stack: listen udp :30303: bind: address already in use

How to solve this?

Jan 16 in Blockchain by slayer
• 29,040 points
63 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

Seems like there is already a geth instance running on your system. To solve this error, you have to terminate that process. 

Use this command to find the pid of geth:

ps -eaux | grep "geth"

Once you get the process id and kill that process using

kill -9 <pid>

 

answered Jan 16 by Omkar
• 65,850 points

Related Questions In Blockchain

0 votes
1 answer

Error while running curl command in Docker Quickstart Terminal

You can get the new version of ...READ MORE

answered Jul 12, 2018 in Blockchain by slayer
• 29,040 points
129 views
+1 vote
5 answers

How to solve "truffle: command not found" error in blockchain?

First try restarting the system and then ...READ MORE

answered Jul 16, 2018 in Blockchain by slayer
• 29,040 points
497 views
+1 vote
4 answers

How to solve “bind: cannot assign requested address” Error?

You must mention in your host.conf file ...READ MORE

answered Jul 31, 2018 in Blockchain by slayer
• 29,040 points
493 views
0 votes
0 answers

Error: Unexpected token o in JSON at position 1

I have been working with Interacting a ...READ MORE

Mar 6 in Blockchain by saeedi
• 120 points

edited Mar 6 by Omkar 116 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
65 views
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer

“geth attach” command shows error: Fatal: Unable to attach to remote geth

Seems like the geth.ipc file is not present in ...READ MORE

answered Jan 16 in Blockchain by Omkar
• 65,850 points
50 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.