Error while running curl command in Docker Quickstart Terminal

0 votes

I am trying tp run a hyperldger fabric on my system for practice.. i am using a 64bit windows 7 system.. And i am using Docker Toolbox.. I have opened the Docker Quickstart Terminal and when i run 

curl -sSL https://goo.gl/iX9dek ¦ bash

i get the following error:

bash: line 1: syntax error near unexpected token `newline' 
bash: line 1: <HTML>
Note:If you get an error running the above curl command, you may have too old a version of curl. Please visit the Prerequisites page for additional information on where to find the latest version.

I tried to update it using yum update curl.x86_64 command but it shows that yum and update are not found..

please help..

Jul 12, 2018 in Blockchain by digger
• 27,620 points
128 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

You can get the new version of curl from https://curl.haxx.se/download.html

You are using the URL https://goo.gl/iX9dek in your command.. It seems that the URL does not exist anymore.. It has
beem shifted to https://raw.githubusercontent.com/hyperledger/fabric/master/scripts/bootstrap-1.0.0.sh

So try executing curl -sSL https://raw.githubusercontent.com/hyperledger/fabric/master/scripts/bootstrap-1.0.0.sh | bash

This should work..

answered Jul 12, 2018 by slayer
• 29,040 points

Related Questions In Blockchain

0 votes
1 answer

Issue to run curl command in windows 7 Docker Quickstart Terminal

Actually, the issue is more likely that ...READ MORE

answered Jun 27, 2018 in Blockchain by ariaholic
• 7,320 points
29 views
0 votes
1 answer

Error while running make command using Fabric 1.0.6

It's a known issue in go 1.9.4: https://github.com/golang/go/issues/23739 While ...READ MORE

answered Jun 26, 2018 in Blockchain by Perry
• 16,450 points
78 views
+1 vote
1 answer

Error while deploying chaincode in IBM Blockchain. Please help.

Try stripping out the 'tree/master' portion of ...READ MORE

answered Apr 26, 2018 in Blockchain by Christine
• 15,790 points
70 views
0 votes
1 answer
0 votes
1 answer

Invalid Batch or signature in Savtooth

This will solve your problem import org.apache.commons.codec.binary.Hex; Transaction txn ...READ MORE

answered Aug 1, 2018 in Blockchain by digger
• 27,620 points
38 views
+1 vote
1 answer
+1 vote
5 answers

How to solve "truffle: command not found" error in blockchain?

First try restarting the system and then ...READ MORE

answered Jul 16, 2018 in Blockchain by slayer
• 29,040 points
495 views
+1 vote
4 answers

What is hf.Registrar.Roles in fabric-ca-client command?

The "hf.Registrar.Roles" attribute is used to control ...READ MORE

answered Jul 11, 2018 in Blockchain by slayer
• 29,040 points
380 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.