I'm getting coredns CrashLoopBackoff error when installing Kubernetes on Ubuntu VM. I've followed the steps as described in Edureka blog

+4 votes

I had followed the installation process as described in the blog for installing kubernetes on Ubuntu VM.

I am getting the pod status as this... coredn issues.

NAMESPACE     NAME                              READY   STATUS             RESTARTS   AGE
kube-system   coredns-68fb79bcf6-24wr9          0/1     CrashLoopBackOff   7          15m
kube-system   coredns-68fb79bcf6-6gzmt          0/1     CrashLoopBackOff   7          15m
kube-system   etcd-kmaster                      1/1     Running            0          16m
kube-system   kube-apiserver-kmaster            1/1     Running            0          17m
kube-system   kube-controller-manager-kmaster   1/1     Running            0          17m
kube-system   kube-flannel-ds-amd64-q49vc       1/1     Running            0          16m
kube-system   kube-proxy-mfqj7                  1/1     Running            0          17m
kube-system   kube-scheduler-kmaster            1/1     Running            0          16m
Nov 23, 2018 in Kubernetes by Raj
• 160 points

edited Jan 11 by Vardhan 445 views
Hey @Raj, are you using Calico or flannel?

Hi Kalgi. I tried with both calico and flannel.

have installed ubuntu 16.04.5 Desktop version in a VM and tried the procedure outlined in the blog.

---------------------

The installation works fine when I install using flannel and also change the proxy to 8.8.8.8 using the command:

     kubectl edit cm coredns -n kube-system

My concern is whether there would be any implication of changing the proxy as mentioned above.

Alright, execute this command and post the output:

kubectl -n kube-system describe pod <coredns-pod-name>
Hey @Raj, any progress with this?
Sorry Kalgi. Thanks for the follow-up.

I got shifted to another project and so couldn't continue with Kubernetes as of now.

Thanks a ton.
Happy to help @Raj, come back whenever you're stuck :)

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes
I have the same issue right now with error on CoreDns... Also dash is running but getting connection refused error.
answered Feb 15 by RANGANATHAN BALAJI
Hey @Balaji, can you show your error log?
Also, is your coreDNS in CrashLoopBackOff state or pending state?

Related Questions In Kubernetes

0 votes
1 answer

Error saying "The specified bucket does not exist" in kubernetes

Bucket is created in another region. Looks like ...READ MORE

answered Aug 31, 2018 in Kubernetes by Kalgi
• 35,800 points
132 views
0 votes
2 answers

NoSuchBucket error when running Kubernetes on AWS

It was a bug on their part. ...READ MORE

answered Sep 4, 2018 in Kubernetes by Nilesh
• 6,900 points
21 views
0 votes
1 answer

Installing Kubernetes on aws gives an error

seems like you are missing region. Try ...READ MORE

answered Oct 4, 2018 in Kubernetes by Kalgi
• 35,800 points
17 views
0 votes
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17 in Others by anonymous
475 views
+3 votes
1 answer

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.