Kubernetes Dashboard - Token login issue

+4 votes

Hello guys i am having some trouble with loging into dashboard with token. I was googling for 3 days and there are explained the same issues on the internet as mine but with the given answers I couldn't solve my problem. 

The problem is: I have installed kubernetes dashboard on my virtual machine. From local browser (from virtual machine) I can easy access to the dashboard with a TOKEN. I can sign in complitely fine, BUT when i want to access to the same dashboard via my computer (not the virtual machine) and i paste TOKEN to where it is required and click Sign IN nothing happens. Can someone please help me how to remotely access to my dashboaard and to solve this issue?

NOTE: Accessing to dashboard (from Virtual Machine (local) and remote from my computer) is working complitely fine but when I want to log in with a token just nothing happens. I don't know why.

I also tried some port forwarding like: ssh -L 8001:localhost:8001 root@<IP> , but did not fix my error.

Accessing localy to dashboard: http://localhost:8001/api/v1/namespaces/kube-system/services/https:kubernetes-dashboard:/proxy/#!/login

Accesing remotely to dashboard (as above, but with the IP of virtual machine): <IP>:8001/api/v1/namespaces/kube-system/services/https:kubernetes-dashboard:/proxy/#!/login

 Thanks a lot.

Nov 21, 2018 in Kubernetes by Denis
• 270 points

edited Nov 26, 2018 by Denis 2,664 views
Hey @Denis, What does it say when you insert the token and try to sign in?
Hi @Kalgi. Actually nothing. When i click Sign In button just nothing happens. No error is displayed, there is just nothing that shows that something would be wrong.

This is how it looks like: http://prntscr.com/llgght
Alright @Denis, i'll try the same and get back to you in sometime.
Ok. Thanks a lot.
Hi , I am also facing the same issue. Anyone got the solution for this issue?

Hi Sal!

Not really. I guess that access to dashboard just isn't possible this way. 

As someone mentioned below:  It cannot be accessed from anywhere other than the master. 

3 answers to this question.

+4 votes
Best answer
answered Nov 23, 2018 by Ali
• 10,430 points

selected Nov 27, 2018 by Denis
Hello @Sarah. Yes I mean directly from my virtual machine where the master is running as you said.
I didn't find a solution for remote access.
Having same issue as me?
Yes, I have the same issue. Even I'm able to access it from the master from my virtual machine but not from my windows browser.
As far as i know, the dashboard is rigged to only work like that. It cannot be accessed from anywhere other than the master. (not even from other nodes in the cluster)

If you'll have a supporting document which says it can be accessed from else where, plz do share the link.

Sarah & Vardhan I also came to the conclusion that accessing to dashboard from anywhere other than the master won't work.

So my solution is: create 1 master (maximal linux install) and 2 nodes (minimal linux install) on the same vCenter and then accessing to my dashboard from my master, where I have installed maximal version with GUI. This is the only way to fix the problem I guess.

Greetings from edureka! Community.

We have reviewed your post and have concluded there is no reason for your post to be flagged. Hence, we have cleared the flag.

Continue to Ask, Learn & Collaborate!

+2 votes

Dashboard should not be exposed publicly using kubectl proxy command as it only allows HTTP connection. For domains other than localhost and 127.0.0.1 it will not be possible to sign in. Nothing will happen after clicking Sign in button on login page.

answered Nov 22, 2018 by Kalgi
• 42,280 points
Thank you for answer and taking your time!
0 votes
Hey @Denis, I did a little more research and found out that your firewall might be disabled which might not let you log-into your dashboard. Could you check if your firewall is enabled?
answered Dec 20, 2018 by Kalgi
• 42,280 points
Hi. What do you mean? Firewall on my local machine or virtual machines?

On my local machine it is enabled but on my virtual machines I had disable it (on master and node).
That's what Kalgi is saying. It should be disabled in VM. But for you, its not working inspite of that right?

Related Questions In Kubernetes

0 votes
3 answers

Kubernetes dashboard status-CrashLoopBackOff

I had the same issue, struggled for days. ...READ MORE

answered Apr 24 in Kubernetes by Bebo
2,655 views
0 votes
1 answer

Kubernetes Dashboard v1.8.3 deployment

You’ve created your ServiceAccount on a different ...READ MORE

answered Aug 27, 2018 in Kubernetes by Kalgi
• 42,280 points
188 views
0 votes
1 answer

Error while creating kubernetes dashboard

The installation fails because there is no ...READ MORE

answered Aug 27, 2018 in Kubernetes by Kalgi
• 42,280 points
434 views
0 votes
1 answer

Unable to access kubernetes dashboard

You’re trying to access a private IP. ...READ MORE

answered Aug 27, 2018 in Kubernetes by Kalgi
• 42,280 points
264 views
0 votes
2 answers

Accessing Kubernetes Web UI (Dashboard)

To access Kubernetes dashboard, you need to ...READ MORE

answered Apr 15 in Kubernetes by Ray
373 views
0 votes
1 answer

How do I sign-in to kubernetes dashboard?

Since version 1.7 Dashboard uses more secure ...READ MORE

answered Sep 7, 2018 in Kubernetes by DareDev
• 6,810 points
167 views
+3 votes
1 answer
0 votes
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17 in Others by anonymous
2,975 views