"failed to create new connection context deadline exceeded." error in Hyperledger Fabric

+2 votes

I am practising the Build your first network tutorial. When I run ./byfn.sh up, I get the following error:

Error: error getting endorser client chaincode: endorser client failed to connect to peer0.org1.example.com:7051 failed to create new connection context deadline exceeded.

How to solve this?

Nov 21, 2018 in Blockchain by slayer
• 29,040 points
1,638 views

4 answers to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
+1 vote
Best answer

Try remove previous docker containers(have mentioned the command below) and then restart the network.

$ docker rm -f $(docker ps -aq) && docker rmi -f $(docker images | grep dev | awk '{print $3}') && docker volume prune

answered Apr 23 by Kiran

selected Apr 23 by slayer
Hi @Kiran. That error got resolved. Now I am getting some binaries related error.

Try re-installing platform-specific binaries. Under the fabric-samples, run the following command:

$ curl -sSL http://bit.ly/2ysbOFE | bash -s 1.2.0

 

+1 vote

It seems like them are old configuration existing which is conflicting with your command. First run  ./byfn.sh down and then bring you network up using  ./byfn.sh up. This should help.

answered Nov 21, 2018 by Omkar
• 65,850 points
Tried it, didn't work. Please help. Another other solution?
0 votes

I was facing the same issue. I tried many solutions but it didn't work. What finally worked for me is updating docker. I executed the below command and restarted the network and the error was solved. 

$ sudo apt-get install docker-engine
answered Apr 24 by Kriti
Updating docker didn't work for me. Any other solutions?
I think the changes I made while trying other solutions also contributed to solving the problem along with updating docker. It was a long time ago, so I don't remember. I'll post once I remember what I had tried.

Okay, so I was trying some solutions and found out the problem was with the peer.listenAdress. Setting it to the right address solved the problem. 

This wasn't what I tried but if it worked for you, could work for others too. I think you should post this as an answer.
0 votes

Check for the peer.listenAdress in your configuration files. I was getting this error because I had set a wrong address and after I set the right address, the error was solved. 

answered Apr 24 by Rajini

Related Questions In Blockchain

+2 votes
2 answers
+2 votes
3 answers

Hyperledger Fabric: Peer Connection error: Failed obtaining connection: Could not connect to any of the endpoints.

 You can extend your /etc/hosts file and make orderer.example.com domain name ...READ MORE

answered Nov 13, 2018 in Blockchain by Omkar
• 65,850 points
429 views
0 votes
1 answer
0 votes
1 answer

Invalid Batch or signature in Savtooth

This will solve your problem import org.apache.commons.codec.binary.Hex; Transaction txn ...READ MORE

answered Aug 1, 2018 in Blockchain by digger
• 27,620 points
38 views
+1 vote
1 answer
+4 votes
2 answers

Hyperledger Fabric issue: orderer client failed to connect to orderer.xxx.net:7050: failed to create new connection

Hey @gujiwork, Try making the following changes: docker-compose-base.yaml and ...READ MORE

answered Nov 5, 2018 in Blockchain by Omkar
• 65,850 points
1,949 views
0 votes
2 answers

How to completely uninstall hyperledger composer?

You might have to uninstall/remove files from ...READ MORE

answered Aug 9, 2018 in Blockchain by slayer
• 29,040 points
1,911 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.