Hyperledger Fabric Error could not assemble transaction err proposal response was not successful

0 votes

I am trying to create a channel and I am running this command:

peer channel create -o orderer.example.com:7050 -c $CHANNEL_NAME -f ./channel-artifacts/channel.tx --tls --cafile /opt/gopath/src/github.com/hyperledger/fabric/peer/crypto/ordererOrganizations/example.com/orderers/orderer.example.com/msp/tlscacerts/tlsca.example.com-cert.pem

It worked well the first time but the second time I got this error:

Error: could not assemble transaction, err proposal response was not successful, error code 500, msg chaincode with name 'mycc' already exists
Nov 19, 2018 in Blockchain by slayer
• 29,350 points
Your package name should be main

2 answers to this question.

0 votes
Best answer

Hey. It seems like you already have a chaincode with name "myacc" (as mentioned in the error). Try changing the name of your smart contract to something other than "myacc" and it should work.

Hope this helps!

Get your Blockchain certification today to learn more about this technology.


answered Nov 19, 2018 by Omkar
• 69,230 points

selected Apr 26, 2019 by Omkar
+2 votes
I think this problem is very simple. The second time you run the chaincode is in the environment that the former chaincode still exists. So prune the net environment and run the chaincode again.
answered Mar 3, 2019 by anonymous
Hello. Thanks for the suggestion. Can you please tell me how to prune the net environment? I am new to hyperledger so I don't know.

Hope its volume prune, command is below

$ docker volume prune

Hi @Bitla. I tried this command but I am getting the following error. 

Error response from daemon: Conflict: volume is in use

What should I do next?

Maybe the volume that you are trying to prune is being used by some other container. Try this command:

$ docker container prune
$ docker volume prune

Hi. I am using nfs file system and this is not working. Please help. 

It should not make any difference even if you are using nfs fille system. It should work. Anyways, try force pruning the volume:

$ docker system prune --volumes --force
Hey @Robin, force pruning is not working.

@Rituja, try this:

$ docker volume rm

Related Questions In Blockchain

0 votes
2 answers
0 votes
1 answer

Hyperledger Fabric peer command not found error.

This error occurs when the system can ...READ MORE

answered Jul 2, 2018 in Blockchain by Omkar
• 69,230 points
0 votes
1 answer

Hyperledger Sawtooth vs Quorum in concurrency and speed Ask

Summary: Both should provide similar reliability of ...READ MORE

answered Sep 26, 2018 in IoT (Internet of Things) by Upasana
• 8,620 points
+2 votes
3 answers

Hyperledger Fabric: Peer Connection error: Failed obtaining connection: Could not connect to any of the endpoints.

 You can extend your /etc/hosts file and make orderer.example.com domain name ...READ MORE

answered Nov 13, 2018 in Blockchain by Omkar
• 69,230 points
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP