unable to start Kubernetes due to so many open files in system

0 votes

I tried creating bunch of pods, services and deployment using Kubernetes, but getting the following errors when I run the kubectl describe command.

for "POD" with RunContainerError: "runContainer: API error (500): Cannot start container bbdb58770a848733bf7130b1b230d809fcec3062b2b16748c5e4a8b12cc0533a: [8] System error: too many open files in system\n"

I terminated all pods and try restarting the machine, but it's not working.I was wondering how to get all the open files and close them at once? Can anyone help me with this?

May 1, 2018 in Kubernetes by Atul
• 10,230 points

1 answer to this question.

0 votes

You can try the following steps:

You can find which process is hogging file descriptors by running the following command:

lsof | awk '{print $2}' | sort | uniq -c | sort -n

You will get a sorted list of open FD counts with the pid of the process. Then you can look up each process w/

ps -p <pid>

If the main hogs are docker/kubernetes, then I would recommend following along on the issue th caesarxuchao reference.

I think it would be helpful for you.

answered May 1, 2018 by shubham
• 7,320 points

Related Questions In Kubernetes

0 votes
1 answer

Kubernetes: Unable to get services in namespace: logs"system:serviceaccount:default:default"

Your approach is wrong here. Namespace is ...READ MORE

answered Oct 27, 2018 in Kubernetes by ajs3033
• 7,280 points
0 votes
1 answer

Unable to attach AWS EBS as volume in Kubernetes aws

You need to set the cloud provider ...READ MORE

answered Oct 10, 2018 in Kubernetes by Kalgi
• 52,370 points
0 votes
1 answer

Unable to open jenkins on the slave- Kubernetes

Execute these commands first and let me ...READ MORE

answered Dec 19, 2018 in Kubernetes by Charlie
+5 votes
2 answers

Redirecting host to service path in kubernetes

What you are trying to do is ...READ MORE

answered Mar 27, 2018 in Kubernetes by DragonLord999
• 8,450 points
0 votes
1 answer

How to use gravitational teleport in a container/kubernetes environment?

You can use teleport to augment kubernetes ...READ MORE

answered Jun 28, 2018 in Kubernetes by ajs3033
• 7,280 points
+1 vote
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17, 2019 in Others by anonymous
+4 votes
1 answer

Installing Web UI (Dashboard):kubernetes-dashboard on main Ubuntu 16.04.6 LTS (Xenial Xerus) server

Follow these steps: $ kubeadm reset $ kubeadm init ...READ MORE

answered Apr 12, 2019 in Kubernetes by Kalgi
• 52,370 points

reshown Apr 12, 2019 by Kalgi 3,704 views
0 votes
4 answers

minikube start is giving OS Type not recognized

I had the same issue. i had ...READ MORE

answered Apr 30, 2019 in Kubernetes by Lisa
Send OTP
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP