Docker on mac error message can't connect to Docker endpoint

0 votes

Hey everyone, I have tried the vagrant devenv for multi-peers network and it worked fine. now I am trying to do the same thing on mac, but I got such err message

vp_1  | 07:21:42.489 [dockercontroller] deployImage -> ERRO 04c Error building images: cannot connect to Docker endpoint
vp_1  | 07:21:42.489 [dockercontroller] deployImage -> ERRO 04d Image Output:
vp_1  | ********************
vp_1  |
vp_1  | ********************
vp_1  | 07:21:42.553 [dockercontroller] Start -> ERRO 05b start-could not recreate container cannot connect to Docker endpoint
vp_1  | 07:21:42.553 [container] unlockContainer -> DEBU 05c container lock deleted(dev-jdoe-04233c6dd8364b9f0749882eb6d1b50992b942aa0a664182946f411ab46802a88574932ccd75f8c75e780036e363d52dd56ccadc2bfde95709fc39148d76f050)
vp_1  | 07:21:42.553 [chaincode] Launch -> ERRO 05d launchAndWaitForRegister failed Error starting container: cannot connect to Docker endpoint

Belowing is my compose file,

vp:
image: hyperledger/fabric-peer
ports:
- "5000:5000"
environment:
- CORE_PEER_ADDRESSAUTODETECT=true
- CORE_VM_ENDPOINT=http://127.0.0.1:2375
- CORE_LOGGING_LEVEL=DEBUG
command: peer node start

I have tried assigning endpoint to "unix:///var/run/docker.sock" and it appear the other err message as belowing

vp_1  | 07:39:39.642 [dockercontroller] deployImage -> ERRO 045 Error building images: dial unix /var/run/docker.sock: connect: no such file or directory
vp_1  | 07:39:39.642 [dockercontroller] deployImage -> ERRO 046 Image Output:
Sep 19, 2018 in Blockchain by digger
• 27,620 points
44 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

While CORE_VM_ENDPOINT set to unix:///var/run/docker.sock, please make sure that var/run/docker.sock exists in your host. please mount it if its not exist.

Also, refer to the following question, Hyperledger Docker endpoint not found

answered Sep 19, 2018 by slayer
• 29,040 points

Related Questions In Blockchain

0 votes
1 answer

Hyperledger Docker: Error building images: cannot connect to Docker endpoint.

Check your container environment variable: CORE_VM_ENDPOINT=unix:///var/run/docker.sock Then if you ...READ MORE

answered Nov 15, 2018 in Blockchain by Omkar
• 65,850 points
35 views
0 votes
1 answer

How to fix "failed to execute script docker compose" error on windows 7?

It seems like the container is not ...READ MORE

answered Jun 27, 2018 in Blockchain by Omkar
• 65,850 points
868 views
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 56,120 points
59 views
0 votes
1 answer

AWS multichain network, "Couldn't connect to the seed node" error

The error says "please check multichaind is ...READ MORE

answered Jul 9, 2018 in Blockchain by slayer
• 29,040 points
101 views
0 votes
1 answer

Getting error while building Bitcoind on MAC OS

First of all try building a non-GUI ...READ MORE

answered Aug 20, 2018 in Blockchain by slayer
• 29,040 points
27 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.