Getting error while building Bitcoind on MAC OS

0 votes

I am trying to build bitcoind and am using the following code:


brew install autoconf automake berkeley-db4 libtool boost miniupnpc openssl pkg-config protobuf qt5


git clone https://github.com/bitcoin/bitcoin.git

cd bitcoin


./autogen.sh

./configure --with-gui=qt5

make

I get the following error:

OBJCXXLD qt/bitcoin-qt

clang: error: unknown argument: '-framework QtNetwork'

clang: error: unknown argument: '-framework QtWidgets'

clang: error: unknown argument: '-framework QtGui'

clang: error: unknown argument: '-framework QtCore'

clang: error: unknown argument: '-framework QtDBus'

clang: error: unknown argument: '-framework QtCore'

make[2]: *** [qt/bitcoin-qt] Error 1

make[1]: *** [check-recursive] Error 1

make: *** [check-recursive] Error 1

How can I solve this?

Aug 20, 2018 in Blockchain by digger
• 26,550 points
40 views

1 answer to this question.

0 votes

First of all try building a non-GUI bitcoind:

make clean

./configure --without-gui

make

This will solve your error.

answered Aug 20, 2018 by slayer
• 29,050 points

Related Questions In Blockchain

0 votes
1 answer
0 votes
1 answer

Error in playground while committing transaction on the ledger

1. Is this transaction is trying to ...READ MORE

answered Jul 27, 2018 in Blockchain by shweta
• 440 points
26 views
0 votes
1 answer
0 votes
1 answer

Protocols used in a distributed/dlt system for the nodes to establish communication

yes all are over TCP/IP connections secured by TLS encryption in hashgraph architecture-hashgraph, ...READ MORE

answered Aug 6, 2018 in Blockchain by ariaholic
• 7,340 points
75 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
140 views
0 votes
1 answer
0 votes
1 answer

'ppa:ethereum' error while installing ethereum on ubuntu

First try: sudo apt-get install --reinstall ca-certificates If ...READ MORE

answered Jul 12, 2018 in Blockchain by slayer
• 29,050 points
167 views
0 votes
1 answer

Not able to build bitcoind on mac.

You have to install pkg-config before running ...READ MORE

answered Aug 23, 2018 in Blockchain by slayer
• 29,050 points
51 views