Throwing error - org openqa selenium SessionNotCreatedException session not created exception

0 votes

I'm trying to run some Selenium tests using the Selenium Chrome Driver, but it is throwing an error:

Starting ChromeDriver 2.23.409699 (49b0fa931cda1caad0ae15b7d1b68004acd05129) on port 42985

Only local connections are allowed.

Exception in thread "main" org.openqa.selenium.SessionNotCreatedException: session not created exception

from unknown error: Runtime.executionContextCreated has invalid 'context': {"auxData":{"frameId":"7576.1","isDefault":true},"id":1,"name":"","origin":"://"}

  (Session info: chrome=54.0.2840.59)

  (Driver info: chromedriver=2.23.409699 (49b0fa931cda1caad0ae15b7d1b68004acd05129),platform=Windows NT 10.0.14393 x86_64) (WARNING: The server did not provide any stacktrace information)

Command duration or timeout: 2.48 seconds

Build info: version: 'unknown', revision: '2aa21c1', time: '2016-08-02 14:59:43 -0700'

System info: host: 'SUJITH', ip: '', 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_101'

Driver info:

    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(

    at java.lang.reflect.Constructor.newInstance(

    at org.openqa.selenium.remote.ErrorHandler.createThrowable(

    at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(

    at org.openqa.selenium.remote.RemoteWebDriver.execute(

    at org.openqa.selenium.remote.RemoteWebDriver.startSession(

    at org.openqa.selenium.remote.RemoteWebDriver.<init>(

    at org.openqa.selenium.remote.RemoteWebDriver.<init>(




    at Selenium.Test2.main(

Why is this happening, and how can I fix it?

Jul 20, 2018 in Selenium by Martin
• 4,320 points
Still not able to run.

getting this error-

Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code.
Exception in thread "main" org.openqa.selenium.SessionNotCreatedException: session not created
from disconnected: unable to connect to renderer
  (Session info: chrome=75.0.3770.142)
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:53'
System info: host: 'admins-MacBook-Pro-8.local', ip: 'fe80:0:0:0:18fb:f5a2:680a:d377%en0', 'Mac OS X', os.arch: 'x86_64', os.version: '10.14.5', java.version: '1.8.0_211'
Driver info: driver.version: ChromeDriver
remote stacktrace: 0   chromedriver                        0x000000010b88b319 chromedriver + 3597081
1   chromedriver                        0x000000010b81af73 chromedriver + 3137395
2   chromedriver                        0x000000010b5c6c6f chromedriver + 695407
Try to look for your Selenium version and then checkout which version of Chrome driver is supported by Selenium Webdriver? Or simply check whether there's any mismatch in versions between Selenium Webdriver and Chrome Driver.
I am still getting the same error for chrome browser "77.0.3865.75" with chromedriver version "77.0.3865.40" . Is that problem resolved for you ? If yes ,Please provide steps here . It would be a great help.

Hey Aravintham, these kind of errors occur when either the chrome browser is updated or the chrome driver is updated and both aren't version compatible. So to resolve such error, update your chrome browser to the latest version and also install the latest chrome driver version supporting browser.

You can choose chrome driver from the below link that will suit your system architecture:

4 answers to this question.

0 votes

Update your chrome driver with latest version. It will work fine.

answered Jul 20, 2018 by Samarpit
• 5,910 points

Updated the chromdriver(latest version)still facing the issue.
chrome driver and chrome browser version are same. Still getting the same.

Did anyone resolve this issue?
Check if both of those updated versions are compatible with each other.
+1 vote
Updating the chrome driver and chrome browser to same latest version resolved my issue
answered Apr 12, 2020 by Vamsi
0 votes

Update the ChromeDriver with your chrome webrowser verion, thats it. it will work

answered Jun 16, 2020 by triplek

You need to call WebDriverManager before instantiating the ChromeDriver object.i.e

1. System.setProperty("" ,"D:/SeleniumJars/chromedriver_win32/chromedriver.exe");

2. WebDriver driver = new ChromeDriver();
Hi @Jaspreet, thank you for your contribution to the Edureka Community.

Register/Sign up on the community to gain points for further contributions. You may ask questions, answer, upvote, and downvote an answer. Each of these would fetch you points and you could be among the top contributors and win exciting merchandise from Edureka.

0 votes
Hi, ones you conform your chrome browser version and chrome driver version are the same.

The second thing you can look is to check why your chrome browser not able to lunch is there any other issue in your system regarding access, try to run home manually if its another server where you running your script.

If any more issue you can post your code and environment you are working with.
answered Aug 24, 2020 by IssueSolver

Related Questions In Selenium

0 votes
1 answer
0 votes
1 answer
0 votes
2 answers

Selenium Webdriver Error: org.openqa.selenium.WebDriverException: unknown error: call function result missing 'value'

Facing Error Exception in thread "main" org.openqa.selenium .WebDriverException: unknown ...READ MORE

answered Mar 5, 2020 in Selenium by anonymous
0 votes
1 answer

Error: org.openqa.selenium.ElementNotInteractableException

Try to use javascriptExecutor to click the ...READ MORE

answered Jul 30, 2018 in Selenium by Samarpit
• 5,910 points
0 votes
2 answers

Finding WebDriver element with Class Name in java

The better way to handle this element ...READ MORE

answered Apr 10, 2018 in Selenium by nsv999
• 5,500 points
0 votes
2 answers

Problem while using InternetExplorerDriver in Selenium WebDriver

enable trusted connection  in internet explorer by ...READ MORE

answered Aug 31, 2020 in Selenium by Sri
• 3,190 points
0 votes
1 answer

Geo-location microphone camera pop up

To Allow or Block the notification, access using Selenium and you have to ...READ MORE

answered May 11, 2018 in Selenium by Samarpit
• 5,910 points
0 votes
2 answers

How to use such xpath to find web elements

xpath are two types. 1) Absolute XPath:    /html/b ...READ MORE

answered Sep 3, 2020 in Selenium by Sri
• 3,190 points
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP