Hyperledger Composer rest server NPM versions

0 votes

Does anyone know which are the right node & npm versions to go with this Hyperledger Rest Server?

I'm using Windows 7 64 Bit and getting this error:

npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.
Jul 13, 2018 in Blockchain by sabby
• 4,350 points
84 views

1 answer to this question.

0 votes

The Hyperledger Composer pre-requisites can be installed on Ubuntu or MacOS. 

You can find it in the documentation here:  https://hyperledger.github.io/composer/latest/installing/installing-prereqs

  • Node: 8.9 or higher (note version 9 is not supported)

  • npm: v5.x

answered Jul 13, 2018 by Christine
• 15,790 points

Related Questions In Blockchain

0 votes
1 answer

Hyperledger Composer: REST Server transaction failed but returns 200 status

You need to return the function calls from the ...READ MORE

answered Nov 6, 2018 in Blockchain by Omkar
• 67,290 points
102 views
0 votes
1 answer

Why hyperledger REST server has PUT method?

Actually, with the PUT method, you don't ...READ MORE

answered Jul 19, 2018 in Blockchain by ariaholic
• 7,320 points
16 views
+3 votes
2 answers

How to run ethereumjs using Node.JS

You need to install testrpc globally on ...READ MORE

answered Mar 27, 2018 in Blockchain by ned_crew
• 1,620 points
127 views
+1 vote
3 answers

Removing double quotes from a string from JSON response in PHP

Just remove the json_encode call, and it should work: $resp ...READ MORE

answered Sep 12, 2018 in Blockchain by digger
• 27,630 points
2,480 views
0 votes
0 answers

Blockchain.info wallet API callback

I am implementing blockchain.info wallet api to ...READ MORE

Jul 4, 2018 in Blockchain by sabby
• 4,350 points
145 views
+1 vote
1 answer

I am unable to change port of composer-rest-server. Please help!

Use full format for running a business ...READ MORE

answered Mar 27, 2018 in Blockchain by Christine
• 15,790 points
261 views