Capistrano deploy error saying end of file reached while deploying to Ubuntu server

0 votes

I was following this blog, to set up my rails server, and after I ran this command, I am getting the following error

EOFError: end of file reached

I'm able to log into the server and i'm getting the same error when i run the following command
cap production deploy:check.

How do get over this error?

Jul 3, 2018 in Other DevOps Questions by Hannah
• 18,570 points

edited Oct 23, 2018 by Kalgi 1,154 views

1 answer to this question.

0 votes

Seems like Capistrano can't connect to the server and is timing out, the most likely culprit is that it's not reading the SSH key correctly. The easiest way to test it would be to try creating an ssh config file:

nano ~/.ssh/config


    IdentityFile ~/.ssh/id_rsa


ssh deploy@

Make sure it connects. (I'm assuming is the IP of your server...)

If that works, try cap production deploy:check again.


What's happening here is the ssh config will feed the extra parameters to any SSH call to that Host (in this case the IP). You could change the Host to '' if you wanted and then you would run ssh if you wanted to create some separation.

answered Jul 3, 2018 by Kalgi
• 52,360 points

Related Questions In Other DevOps Questions

0 votes
1 answer

How to deploy to BlueMix: 404 Error

I have the same error. I think ...READ MORE

answered Jul 16, 2018 in Other DevOps Questions by Kalgi
• 2,680 points
0 votes
1 answer

Is it possible to have a link to raw content of file in Azure DevOps

Sure, here's the call for the rests: GET ...READ MORE

answered Feb 10, 2022 in Other DevOps Questions by Bhavitha
• 1,000 points
0 votes
1 answer

Use vagrant to update $PATH of guest vm

Just try the below script: mvm.vm.provision :shell, :inline ...READ MORE

answered May 1, 2018 in Other DevOps Questions by shubham
• 7,340 points
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 27, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
+2 votes
1 answer
0 votes
1 answer
0 votes
1 answer

Unable to Pull image from ERROR x509: certificate signed by unknown authority

Download necessary CA certificate. "/etc/ssl/certs/ca-certificates.crt", -> Debian/Ubuntu "/etc/pki/tls/certs/ca-bundle.crt", ...READ MORE

answered Jul 3, 2018 in Other DevOps Questions by Kalgi
• 52,360 points