NPM Error While Installing Lisk Dependencies

0 votes

How do I resolve this npm install error?

I cloned the Lisk blockchain application platform and ran npm install and cannot seem to find a solution.

I have a shallow understanding of npm and debugging these types of errors.

If someone would like to teach me how to better think about these problems so that I could better solve them myself in the future I would be grateful.

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/Cellar/node/8.6.0/bin/node',
1 verbose cli   '/usr/local/bin/npm',
1 verbose cli   'install' ]
2 info using npm@5.5.1
3 info using node@v8.6.0
4 verbose npm-session 1b07b056f8329c9c
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall lisk@0.9.8
7 info lifecycle lisk@0.9.8~preinstall: lisk@0.9.8
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 silly install loadIdealTree
11 silly install cloneCurrentTreeToIdealTree
12 silly install loadShrinkwrap
13 silly install loadAllDepsIntoIdealTree
14 info lifecycle sodium@2.0.1~prepack: sodium@2.0.1
15 info lifecycle sodium@2.0.1~postpack: sodium@2.0.1
16 silly pacote git manifest for sodium@github:LiskHQ/node-sodium#716de00 fetched in 16581ms
17 silly resolveWithNewModule sodium@2.0.1 checking installable status
18 silly currentTree lisk@0.9.8
18 silly currentTree ├── abbrev@1.1.1
18 silly currentTree ├── accepts@1.3.4
18 silly currentTree ├─┬ acorn-dynamic-import@2.0.2
18 silly currentTree  └── acorn@4.0.13
18 silly currentTree ├─┬ acorn-jsx@3.0.1
18 silly currentTree  └── acorn@3.3.0
18 silly currentTree ├── acorn@5.1.2
18 silly currentTree ├── after@0.8.2
18 silly currentTree ├── ajv-keywords@2.1.0
18 silly currentTree ├── ajv@5.2.3
18 silly currentTree ├── align-text@0.1.4
18 silly currentTree ├── amdefine@1.0.1
53 verbose lifecycle sodium@2.0.1~preinstall: CWD: /Users/sufuninja/Projects/lisk/node_modules/sodium
Jun 19, 2018 in Blockchain by aryya
• 7,450 points

1 answer to this question.

0 votes

Meet the lib sodium fails. You're using

node v8.6.0
npm  v5.5.1

If you've installed automake autoconf libtool successfully then I would suggest using

node v6.12.0
npm  v4.5.0

As the documentation suggest.

answered Jun 19, 2018 by charlie_brown
• 7,720 points

Related Questions In Blockchain

0 votes
1 answer

'ppa:ethereum' error while installing ethereum on ubuntu

First try: sudo apt-get install --reinstall ca-certificates If ...READ MORE

answered Jul 12, 2018 in Blockchain by slayer
• 29,350 points
0 votes
1 answer

Hyperledger error while installing binaries

This seems like a problem with the ...READ MORE

answered Aug 9, 2018 in Blockchain by digger
• 26,740 points
0 votes
1 answer

Fatal error while installing web3 node.

Try to add git config by executing ...READ MORE

answered Aug 10, 2018 in Blockchain by digger
• 26,740 points
0 votes
1 answer

Hyperledger Composer rest server NPM versions

The Hyperledger Composer pre-requisites can be installed ...READ MORE

answered Jul 13, 2018 in Blockchain by Christine
• 15,790 points
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
0 votes
1 answer

Hyperledger Sawtooth vs Quorum in concurrency and speed Ask

Summary: Both should provide similar reliability of ...READ MORE

answered Sep 26, 2018 in IoT (Internet of Things) by Upasana
• 8,620 points
0 votes
1 answer

npm hfc@0.6.2 not properly installing

this is harmless, the hfc module should ...READ MORE

answered Jul 24, 2018 in Blockchain by charlie_brown
• 7,720 points
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP