Command python setup py egg info failed with error code 1 in tmp pip-build-8nhf9w2t grpcio

+1 vote

Hi Guys,

I am trying to install tensorflow in my docker. But it shows me the below error.

  Using cached
    Complete output from command python egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-f3unmpsj/grpcio/", line 191, in <module>
        if check_linker_need_libatomic():
      File "/tmp/pip-build-f3unmpsj/grpcio/", line 152, in check_linker_need_libatomic
      File "/usr/lib64/python3.6/", line 729, in __init__
        restore_signals, start_new_session)
      File "/usr/lib64/python3.6/", line 1364, in _execute_child
        raise child_exception_type(errno_num, err_msg, err_filename)
    FileNotFoundError: [Errno 2] No such file or directory: 'cc': 'cc'
Command "python egg_info" failed with error code 1 in /tmp/pip-build-f3unmpsj/grpcio/

May 16, 2020 in Machine Learning by akhtar
• 38,180 points

1 answer to this question.

+1 vote


You may get this error because of older version of pip. You can upgrade your pip by using the below command.

$ pip3 install --upgrade setuptools
$ pip3 install --upgrade pip

Hope this will help!

If you need to know more about Python, join Python certification course online today.


answered May 16, 2020 by MD
• 95,240 points
Thanks Man, I looked all over the internet and you had the line I needed ! Great Stuff !
This worked! Thanks much
Thank you man. Worked like magic!
The latest version of setuptools is 49.6.0  wich can install Mask_RCNN  from
Попробовал обновить pip - не помогло, просто пришлось его переустановить и снова ползать по интернету. Windows XP 32bit

Вы решаете свою проблему?
Thanks this worked for me.
it works, magic!

Related Questions In Machine Learning

0 votes
1 answer
0 votes
11 answers
0 votes
1 answer

Equivalent for easy_install & pip

For pip you can check the User ...READ MORE

answered Nov 28, 2018 in Python by SDeb
• 13,290 points
0 votes
2 answers
0 votes
1 answer

error: command 'gcc' failed with exit status 1

Hi@akhtar, I don't know which steps you followed. ...READ MORE

answered Sep 6, 2020 in Machine Learning by MD
• 95,240 points