ModuleNotFoundError No module named pyttsx3

+2 votes

I am trying to import pyttsx3 module in my python code, but It shows me the below error. 

>>>Import pyttsx3 
ModuleNotFoundError: No module named 'pyttsx3

How can I solve this error?

Apr 24, 2020 in Python by akhtar
• 38,240 points

2 answers to this question.

+1 vote


To avoid this error you have to install this module in your system using the below command.

$ pip install pyttsx3
$ conda install pyttsx3

Hope this will help.

answered Apr 24, 2020 by MD
• 95,440 points
I tried with pip installation but that shows that pyttsx3 is already installed and satisfies all requirements. But when I write import pyttsx3 it comes with error : Unable to import 'pyttsx3'

Hi, @There,

Could you please mention which version of Python you are working with?

 For me, pyttsx3 wasn't working with Python3.5.

To fix this, Inside PyCharm, you can do one thing-> File -> Settings -> Project: -> Project Interpreter.
Then click on the "+" sign available beside the package-table. Next, in the popped-up window,  search for the package "pyttsx3". 

Then I select the pyttsx3-package from the search result and click on the 'Install Package' button. Once the installation completes, your error problem might get resolved.


You can also try this

engine = pyttsx3.init('dummy') or engine = pyttsx.init('dummy')
I have done this and even installed pypiwin32 but it is showing the same error. what should I do

Hello @Lakshay,

Start a power shell window, then install 'pipenv' using  pip install -u pipenv, which is an improved pip replacement.Then use pipenv instead of pip as this will create it's own Pipfile and virtualenv.Now you can install pyttsx3 using pipenv install pyttsx3 This will create a Pipfile and a Pipfile.lock . Otherwise check that your python interpreter is set correctly in "Run/Debug configurations". If it's not in that list then you can add a new python interpreter via the Preferences->Project->Project Interpreter option.

yes this worked for me.
I am not able to import pyttsx3 and pipenv

please mail me at

Hello @Atharva,

What error you are facing?

why I get this error :

Traceback (most recent call last):
  File "/Users/mac/Desktop/AI", line 2, in <module>
    import pyttsx3
ModuleNotFoundError: No module named 'pyttsx3'

Hi, @Sultan,

Start a pyCharm terminal window, then install 'pipenv' which is an improved pip replacement as follows:  

pip install -u pipenv 

Then use pipenv instead of pip as this will create it's own Pipfile and virtualenv. You can install pyttsx3 as follows:

 pipenv install pyttsx3
I tried everything to import pyttsx3

but it is showing:

Traceback (most recent call last):
  File "F:\#Best\.py\", line 12, in <module>
    import pyttsx3
ModuleNotFoundError: No module named 'pyttsx3'

I used pipenv but nothing worked.

Same thing is happening with Tensorflow, Pytorch and many other external modules.


If you get an idea regarding my problem.

mail me at


Hey, @Atharva,

Which version of Python your Pycharm is set and on which version of Python you installed the module, please post the versions here. You can do more things, Go to File -> Settings -> Project:.. -> Project Interpreter, and check which version of Python you run on the project. Then go to the CMD/ terminal and write pip -V and it will tell you the pip version and the Python one. Might be a different version.

At a guess - installing the correct library into your environment would help.

I don’t know if you are using a virtual environment - they certainly recommend, but in your working environment (i.e. the same environment you are trying to run the script) execute this command :

pip install pyttsx3 

    I think you are missing the pyttsx3 package.

    Hello, @Atharva,

    Regarding the error, you are facing, all the solutions whichever is possible to resolve the issue will be mentioned here, you can easily come here and have a look. 

    It may happen that somebody else might have face the same error and can get help from the discussion here.

    I hope you will understand and hopefully the issue will be sorted out soon!!!

    I am also facing the same problem but have resolved this by installing the wheel.

    pip install wheel

    Try this
    0 votes
    If you have installed Anaconda  Navigator then open it and follow the steps

    1. On CMD.exe Prompt click on Launch

    2. On CMD pip install pipenv

    3. pipenv install pyttsx3

    4. Open the Eclipse IDE and go to Windows then Preferences

    5. Click on PyDev

    6. Click on Interpreters

    7. Click on Python Interpreters

    8. Click on Libraries then New Folder

    9. C:\Python\Python3.8.2\lib\site-packages

    10. Select the folder

    11. Click Apply and Close

    After all the steps it should work because I was facing the same problem and I solved it.
    answered Oct 12, 2020 by Jamil

    Related Questions In Python

    0 votes
    2 answers

    ModuleNotFoundError: No module named 'pythoncom' in pyttsx3

    even i faced the same problem ...just ...READ MORE

    answered Jun 2, 2020 in Python by anonymous
    0 votes
    1 answer

    ModuleNotFoundError: No module named 'pyttsx3'

    Hello @SUHRID, For your query you can refer ...READ MORE

    answered Oct 7, 2020 in Python by Niroj
    • 82,880 points
    +1 vote
    3 answers
    0 votes
    2 answers
    +1 vote
    2 answers

    how can i count the items in a list?

    Syntax :            list. count(value) Code: colors = ['red', 'green', ...READ MORE

    answered Jul 7, 2019 in Python by Neha
    • 330 points

    edited Jul 8, 2019 by Kalgi 4,212 views
    0 votes
    1 answer
    +5 votes
    6 answers

    Lowercase in Python

    You can simply the built-in function in ...READ MORE

    answered Apr 11, 2018 in Python by hemant
    • 5,790 points
    +2 votes
    3 answers

    ModuleNotFoundError: No module named 'cv2'

    Hi@akhtar, This error may occur if you didn't install ...READ MORE

    answered Apr 9, 2020 in Python by MD
    • 95,440 points
    0 votes
    1 answer

    ModuleNotFoundError: No module named 'Foundation'

    Hi@akhtar, By default Foundation module comes with Anaconda ...READ MORE

    answered Apr 24, 2020 in Python by MD
    • 95,440 points
    webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP