error message while running

0 votes

The following is a script to call an API. But I am getting the following error message while running it:

Traceback (most recent call last):
  File "user_audit.py", line 2, in <module>
    import requests
  File "c:\Python27\lib\site-packages\requests\__init__.py", line 60, in <module>
    from .packages.urllib3.exceptions import DependencyWarning
  File "c:\Python27\lib\site-packages\requests\packages\__init__.py", line 29, in <module>
    import urllib3
ImportError: No module named urllib3
 

I've confirmed that packages is up to date, tried uninstalling and reinstalling it, but nothing has worked so far. Can someone help?

Feb 25 in Apache Kafka by nguyen
• 120 points
22 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
+1 vote

Ideally, installing the urllib3 module should solve this error. I am not sure how you installed it so I am posting the command to install urllib3 which helped me solve this error:

$ pip install urllib3

If you used the same command to install and you are still getting this error, please provide more info: code, Operating System, Python version, etc. 

answered Feb 25 by Omkar
• 65,820 points

Related Questions In Apache Kafka

0 votes
1 answer

Re-balancing error while reading messages from Kafka.

rebalance.backoff.ms defines the time for which Kafka ...READ MORE

answered Jul 9, 2018 in Apache Kafka by Shubham
• 12,110 points
258 views
0 votes
1 answer

How to commit message offsets in Kafka for reliable data pipeline?

You can use auto.commit.enable to allow Kafka ...READ MORE

answered Jul 9, 2018 in Apache Kafka by Shubham
• 12,110 points
161 views
0 votes
1 answer

Getting error in schema-registry start command

Seems like you have not started Zookeeper ...READ MORE

answered Jan 8 in Apache Kafka by Omkar
• 65,820 points
96 views
0 votes
1 answer
0 votes
3 answers
0 votes
2 answers

I'm getting following error, while i'm running code in windows xp service pack 3 with JDK 6 version.

Till you send the code, I would ...READ MORE

answered May 16, 2018 in Java by Meci Matt
• 9,400 points
112 views
0 votes
1 answer

Error while running make command using Fabric 1.0.6

It's a known issue in go 1.9.4: https://github.com/golang/go/issues/23739 While ...READ MORE

answered Jun 26, 2018 in Blockchain by Perry
• 16,450 points
77 views
+2 votes
3 answers

Permission denied error while running a simple job in Jenkins

Hey @Hannah, try changing the permissions using ...READ MORE

answered Oct 25, 2018 in Jenkins by krishti
2,841 views
0 votes
1 answer

Error while running curl command in Docker Quickstart Terminal

You can get the new version of ...READ MORE

answered Jul 12, 2018 in Blockchain by slayer
• 29,040 points
126 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.