Why nginx is not accessible from Swarm worker node

0 votes

I've done the following:

Created a service container using below command

docker service create -p 8181:80 --name mysvc1 ngnix

Worker node and manager node is ready.

Service is running on manager

The container is running on the manager.

EC2 instances created

Security Group configured

Nginx service is accessible from manager node public IP.

If nginx is running on manager node. Why nginx is not accessible from Swarm worker node.

Jan 2, 2019 in Docker by Ali
• 11,300 points
680 views

1 answer to this question.

0 votes

Hey @Ali, your steps look perfectly fine but what I noticed is, you have created the service on the port 80 which is bound to 8181 port. Check if you've disabled the firewall on the worker node. 

To disable the firewall, execute the following command:

sudo service ufw stop

Also, in your security groups, just open all TCP connections to form a network between the worker and the master nodes.

answered Jan 2, 2019 by Vishnu

Related Questions In Docker

0 votes
1 answer

How to remove a worker node from the docker swarm cluster?

Hi@akhtar, To remove a worker node from the ...READ MORE

answered Dec 24, 2020 in Docker by MD
• 95,140 points
275 views
+1 vote
1 answer
+2 votes
1 answer
+3 votes
4 answers

Not able to connect worker nodes to the swarm. Connection refused error

This definitely has to be a firewall issue. ...READ MORE

answered Apr 26, 2019 in Docker by Vaidya
11,216 views
+1 vote
4 answers

COPY is not working in Docker

I had the exact same issue. I ...READ MORE

answered May 6, 2019 in Docker by Emilia
10,850 views