Blue prism- Getting “Cannot create ActiveX component.” error when interacting with Excel VOB operations

0 votes

I am doing a basic exploration on RPA using Blue prism. When I interacting with Excel VBO operation (Create instance) BP throwing following error.

Internal : Could not execute code stage because exception thrown by code stage: Cannot create ActiveX component.

Object flow:

  1. Start
  2. Create instance
  3. Open work book
  4. Get worksheet as collection

Steps tried to resolve the issue: Re registered exes both excel and blue prism but no luck.

Error:

error

Oct 9, 2018 in RPA by eatcodesleeprepeat
• 4,670 points
1,586 views

2 answers to this question.

0 votes

I've resolved this problem by following the below steps:

Actually this is happening because I've JAB dll's in various locations. You have to delete all the JAB file which is there in the following locations and by executing the following commend you can see all Jab related files sitting in your machine.

dir c:\*ccess*ridge*.dll, c:\*ccess*ridge*.jar, c:\accessibility.properties /s /b

Locations where all JAB files needs to be removed:

  1. Windows32
  2. SysWOW64
  3. Prism Limited\Blue Prism Automate

This solution will work for only 64-bit windows 7 or higher version of OS

1)Make sure you have installed jre 1.7 or higher version (1.7+ version will have JAB in build, so you don't need to install it externally)

2)Maker sure you have pasted below files under "Blue Prism Limited\Blue Prism Automate" Copy these files from installed jre\bin

  • JavaAccessBridge-64.dll
  • JAWTAccessBridge-64.dll
  • WindowsAccessBridge-64.dll

3) Enable JAB from windows control panel.

Now try to spy any java application. It should be working. Cheers!! :)

answered Oct 9, 2018 by Priyaj
• 56,520 points
+1 vote
I had faced this issue when i had activated a plug in the excel file. I suspect that the error is caused because the plugin i added in the excel made it unable to create the ActiveX component. I identified this when uninstalled the plugin from excel and then tried to create the instance and it was working.

I have a workaround for the issue which was implemented. Instead of creating an instance for the workbook, directly use the start process action in the utillity environment. we can provide the filepath here and then launch the workbook directly. Later you have to attach to the workbook and this will provide you an output as handle, which you can use for further actions.
answered Apr 2 by anonymous
Hi I am trying to understand your alternate solution, but not much clear about it. Can you please explain it step by step or share some screenshot to give better idea about your solution? I was also looking solution for the similar problem.
import the VBO Utility and create action and put file path it will open excel.it worked for me.
Hi Shital, thanks for sharing your solution. Can you also share some screenshot showing how you resolved the issue?

Related Questions In RPA

0 votes
1 answer

Blue Prism Error - Internal : The specified item was not locked by this business object

Well, the answer is simple - the ...READ MORE

answered Oct 10, 2018 in RPA by Priyaj
• 56,520 points
1,320 views
0 votes
1 answer

In Blue Prism how to split excel column data into TWO columns

This is how I am doing it. Dim ...READ MORE

answered Oct 15, 2018 in RPA by Priyaj
• 56,520 points
1,481 views
0 votes
1 answer

Create a email login object using basic blue prism

Reset the password by going ahead with the ...READ MORE

answered Nov 2, 2018 in RPA by Priyaj
• 56,520 points
278 views
+2 votes
1 answer

How to extract data from website and save it to excel using Blue Prism?

Hey, you can use following steps to ...READ MORE

answered Aug 19 in RPA by Abha
• 22,870 points
207 views
0 votes
2 answers

Limitations of Blue Prism and Automation Anywhere

Sub task can return false positive to ...READ MORE

answered Mar 7 in RPA by anonymous
1,087 views
0 votes
2 answers

Open password protected Excel spreadsheet with UiPath

Want to open Excel, the first thing ...READ MORE

answered Mar 7 in RPA by AllisonE
• 180 points
553 views
0 votes
1 answer

Error while spying the element Index outside bounds:array:BluePrism Java app

This solution will work for only 64-bit ...READ MORE

answered Oct 22, 2018 in RPA by Priyaj
• 56,520 points
476 views
0 votes
1 answer

Error while spying the element Index : outside the bounds of the array :BluePrism Java app

Only for 64-bit windows 7 or higher version ...READ MORE

answered Oct 24, 2018 in RPA by Priyaj
• 56,520 points
421 views
0 votes
1 answer

Using GLobal Send Keys how to send PrtScr in Blue Prism?

Navigate stage with Global Sendkey and text ...READ MORE

answered Oct 24, 2018 in RPA by Priyaj
• 56,520 points
1,812 views
0 votes
1 answer

Compare and find desired result from a table

Try doing simpler one first - reading ...READ MORE

answered Nov 12, 2018 in RPA by Priyaj
• 56,520 points
39 views